RPM/Speedometer/Fuel Gauges gone crazy? - DodgeForum.com



1st Gen Dakota '96 & Older Dakota's

RPM/Speedometer/Fuel Gauges gone crazy?

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-27-2008, 12:19 PM
JohnTheodore JohnTheodore is offline
Thread Starter
 
Join Date: May 2007
Posts: 37
Default RPM/Speedometer/Fuel Gauges gone crazy?

So sporadically this last week, when I drive.. the RPM gauge will go crazy, dropping to 0, then up to 3000, and anywhere inbetween. but the engine sounds fine, it's not actually doing these things, the gauge just says it is. As well the speedometer goes from 65, to 0, and anywhere in between, but I'm maintaining a constant speed(65).

I remember about a year ago my fuel gauge doing this, and it hasn't worked since. It doesn't show how much gas I have in the tank. It is always on empty according to the gauge, but I'm usually at least 3/4 full. My gas gauge will show when I'm on empty, the yellow gas tank symbol will light up, but it won't ever show how much gas I have in the tank via the gauge.

Anyone know what is causing the gauges to go crazy? Sometimes the speedometer/RPM works normal, sometimes they go crazy. How do these systems work? is something loose? Any help is appreciated.

Regards,
John
Reply With Quote
  #2  
Old 07-27-2008, 12:35 PM
zman17's Avatar
zman17 zman17 is offline
Retired Moderator - RIP
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

I think you have more than one prob!
Reply With Quote
  #3  
Old 07-27-2008, 12:38 PM
zman17's Avatar
zman17 zman17 is offline
Retired Moderator - RIP
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

But kind of hard to help since there is no info abouut the vehicle! It is Dakota right?
Reply With Quote
  #4  
Old 07-27-2008, 02:05 PM
JohnTheodore JohnTheodore is offline
Thread Starter
 
Join Date: May 2007
Posts: 37
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

o yea, sorry. It's a 1995 Dodge Dakota Sport Pickup, 113k miles. 4wd. 3.9L engine. The truck runs great, I don't have any problems. Just these gauges.
Reply With Quote
  #5  
Old 07-27-2008, 08:04 PM
peckens peckens is offline
Professional
 
Join Date: Jul 2006
Vehicle: 94 dakota
Location: omaha
Posts: 130
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

dont worry your not alone, i swear every single usmc HMWV has the exact same problem semper fi
Reply With Quote
  #6  
Old 07-27-2008, 11:09 PM
JohnTheodore JohnTheodore is offline
Thread Starter
 
Join Date: May 2007
Posts: 37
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

huh?
Reply With Quote
  #7  
Old 07-27-2008, 11:17 PM
Crazy4x4RT's Avatar
Crazy4x4RT Crazy4x4RT is offline
Offroad Dakota Moderator
 
Join Date: Aug 2007
Vehicle: 93 Dakota
Location: NM
Posts: 10,852
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

Sounds like you got an eletrical problem. Check your ground and power wires.
Reply With Quote
  #8  
Old 07-27-2008, 11:19 PM
Crazy4x4RT's Avatar
Crazy4x4RT Crazy4x4RT is offline
Offroad Dakota Moderator
 
Join Date: Aug 2007
Vehicle: 93 Dakota
Location: NM
Posts: 10,852
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

Here is a diagram http://www.mitchell-auto.ru/UserFile...-dakota-wd.pdf
Reply With Quote
  #9  
Old 07-28-2008, 09:46 AM
Bad96_3.9's Avatar
Bad96_3.9 Bad96_3.9 is offline
All Star
 
Join Date: May 2006
Vehicle: 1996 2wd 318 Dakota
Location: Crawfordville, FL
Posts: 867
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

i would check the plug going into the back of the cluster too, mine had backed out a little and the lights for the gauges stopped working all i had to do was push it back in, it was just barely unplugged. but check grounds too like crazy said.
Reply With Quote
  #10  
Old 07-28-2008, 10:43 AM
JohnTheodore JohnTheodore is offline
Thread Starter
 
Join Date: May 2007
Posts: 37
Default RE: RPM/Speedometer/Fuel Gauges gone crazy?

So I checked all the grounds I could find. some of them under the hood, were a little rusty. So I undid them, took a wire brush to them until there was bare metal all over, and I put them back. Still the same problem though.

Bad96_3.9, where is this plug? I have to take out the instrument panel..and there is some plug behind there?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Why engine sticks too far in driver compartment Ro$$ Dodge Ram Van 5 10-07-2015 12:15 AM
Evaporator Seal Replacement ginpunk 3rd Gen Durango 2 09-29-2015 09:08 PM
p1762 hell hflak Dodge Ram Van 5 09-27-2015 08:40 AM
[3rd Gen : 96-00]: Gauges twitching when ignition is off. MJSchutt Dodge Caravan 4 09-21-2015 10:17 AM
[4th Gen : 01-07]: Solved Grand Caravan Crazy gauges FRR Dodge Caravan 0 09-03-2015 03:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 01:05 AM.