Go Back   DodgeForum.com > Dodge Trucks > Dodge Dakota > 1st Gen Dakota
Sign in using an external account
Register Forgot Password?


1st Gen Dakota '96 & Older Dakota's

1993 dakota 3.9l magnum, poor gas mileage

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-20-2011, 04:12 AM
smiley_1612 smiley_1612 is offline
Registered User
 
Join Date: Sep 2011
Vehicle: 1993 dodge dakota 4X4
Location: MN
Posts: 4
Default 1993 dakota 3.9l magnum, poor gas mileage

I got a 1993 dakota with the 3.9, 200,000 miles on it. When i first got it a few years ago, i was getting 16-20 mpg pretty consistantly. Then all of a sudden it dropped to 9-11 mpg. Never lost any power, still runs great but the exhaust smells funny, like its rich and its a very strong smell. No check engine lights ever come on. No smoke. No cat converter. Recently replaced plugs, wires, cap and rotor. Replaced air filter also. What should I do next?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 09-20-2011, 06:52 AM
4x4Dakota93 4x4Dakota93 is offline
Veteran
 
Join Date: Oct 2009
Vehicle: 93 dakota 4x4 5 speed
Location: Corpus Christi, TX
Posts: 258
Default

O2sensor could of failed, I also have a 93 3.9, and I've never seen a check engine light, did u manually check for codes? Key in ignition, on off on off on off on, wait and count slow flashes then fast flashes for codes?
Reply With Quote
  #3  
Old 09-21-2011, 01:40 AM
smiley_1612 smiley_1612 is offline
Registered User
 
Join Date: Sep 2011
Vehicle: 1993 dodge dakota 4X4
Location: MN
Posts: 4
Default

Thanks for the reply, i found some codes stored in there. Turns out i got 51 for oxygen sensor stuck on lean position, 21 for oxygen sensor circuit, 32 for EGR system, and 12 for memory standby power lost. What does the code 12 do?
Reply With Quote
  #4  
Old 09-21-2011, 01:54 AM
dodgerules86's Avatar
dodgerules86 dodgerules86 is offline
Champion
 
Join Date: Dec 2003
Vehicle: 1996 Dakota 4x4, 3.9L, extended cab, automatic.
Location: Sycamore, Illinois (displaced to Arkansas)
Posts: 4,121
Default

Don't worry about code 12. Pretty much comes up all the time (it's supposed to mean battery disconnected within last 100-or-so key-on's, but, it usually appears all the time).
__________________
If parts ain't flyin', you ain't tryin'.
1996 Dodge Dakota, 4x4, extended cab, 3.9L, automatic. - my baby
2012 VW Jetta Premium with Nav, 2.0L TDI diesel, 6-speed manual - the daily
Traded: 2009 Toyota Corolla S, 1.8L, 5-speed manual
Reply With Quote
  #5  
Old 09-21-2011, 04:28 PM
kahanabob kahanabob is offline
Captain
 
Join Date: Sep 2006
Posts: 568
Default

my 90 also has bad mileage, checked codes (first time ever) see blinking check engine light but what am i looking for in the blinks, all look the same to me and all run together?
don't mean to hijack here but my issue is like posters.
Reply With Quote
  #6  
Old 09-21-2011, 11:04 PM
g. man's Avatar
g. man g. man is offline
Veteran
 
Join Date: Apr 2011
Vehicle: '93 Dak, 3.9 5 speed.
Location: Idaho
Posts: 259
Default

OP- Probably need to replace O2 sensor. My mileage increased when I did mine. And from the codes, that's a good bet.

-There is a good write up in the FAQ.
__________________
Reply With Quote
  #7  
Old 09-24-2011, 10:59 PM
smiley_1612 smiley_1612 is offline
Registered User
 
Join Date: Sep 2011
Vehicle: 1993 dodge dakota 4X4
Location: MN
Posts: 4
Default

Pulled EGR valve out and found the stem was locked up. Put a new one in and it works good now. Still gotta do the o2 sensor yet.
Reply With Quote
  #8  
Old 09-03-2012, 02:43 PM
Womanji Womanji is offline
Registered User
 
Join Date: Sep 2012
Posts: 1
Default

Having the same gas mileage problem with my step-sons Dakota. have replaced the egr and the map sensor but it has not helped the mileage at all. Will try the o2 sensor next I guess. Extremely frustrating for a first semester college student spending all his money on gas, he only gets about 7 mpg.
Reply With Quote
Old 09-03-2012, 02:43 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 08:43 AM.

Internet Brands, Inc.


Contact Details & Emails