Go Back   DodgeForum.com > Dodge Trucks > Dodge Dakota > 1st Gen Dakota
Sign in using an external account
Register Forgot Password?


1st Gen Dakota '96 & Older Dakota's

1990 3.9L won't start

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-14-2006, 12:07 AM
91dakota2wd 91dakota2wd is offline
Garage is empty, add now
 
Join Date: Feb 2006
Posts: 34
Default 1990 3.9L won't start

Picked up a 1990 4x4 3.9L stick shift. It won't fire. It'll turn over good but has no spark. I searched this sight for this problem but most posts were related to newer post 1992 trucks which I think have more computer "stuff" than mine, hopefully anyway. Will the engine have spark if the fuel pump in the tank is bad? Previous owner said he thought the fuel pump was bad so he quit driving it.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 06-14-2006, 12:09 AM
91dakota2wd 91dakota2wd is offline
Garage is empty, add now
 
Join Date: Feb 2006
Posts: 34
Default RE: 1990 3.9L won't start

Forgot to add that the guy took most of the underside of the dash out to replace the heater core which was leaking but gave up after it was all out.
Reply With Quote
  #3  
Old 06-14-2006, 01:18 AM
erock92kota erock92kota is offline
Professional
Garage is empty, add now
 
Join Date: May 2006
Location:
Posts: 200
Send a message via AIM to erock92kota Send a message via Yahoo to erock92kota
Default RE: 1990 3.9L won't start

I would imagine it would have spark if the pump was bad. Did you look into the cap,rotor, wires or anything like that yet??? See if the pickup under the distributor looks nasty or not. But thats typically a case of stalling. Theres an interuptor that spins under that pickup that may have come loose. It happened to one of mine once and it wouldnt fire. Did you check the connections to the coil? Maybe you are having an auto shutdown issue like some other people and can try swapping the relay with one of the other ones. I believe on your truck it would still be #3 the one in the middle. I could be wrong on that tho. I know that it also runs the fuel pump but I have heard it is linked to the coil also. Other then that I would check all the wiring connections and look for corrosion, broken wires, bad connections, etc......
__________________
My wife says my truck reminds her of the Black Pearl. It's black, cursed, and sometimes an eerie fog follows it. Nice.........
Reply With Quote
  #4  
Old 06-14-2006, 01:19 AM
dodgerules86's Avatar
dodgerules86 dodgerules86 is offline
Champion
Garage is empty, add now
 
Join Date: Dec 2003
Vehicle: 1996 Dakota 4x4, 3.9L, extended cab, automatic.
Location: Sycamore, Illinois (displaced to Arkansas)
Posts: 4,121
Default RE: 1990 3.9L won't start

Your engine is not a Magnum model, but I don't think the operating principle (or, computer controls, perhaps) is much differant. Use this if your engine is fuel injected, otherwise, to tell you the truth, I've never delt with a carberated engine.
When you turn the key to the "ON" position (not "START") you should hear the fuel pump turn on for a few seconds. You can also disconnect a fuel line (relieve fuel line pressure first) and turn on for a few seconds with line directed twords bucket (do NOT disconnect the rubber hose connecting the two fuel rails, as per what the manual says), OR you can attach a fuel pressure guage to the fuel rail.
Test the fuel pump relay (link below)
If fuel pump does not show to be working, remember to check for voltage AT the pump before going and buying a new one. (On the 1996 Dakota, the dark green/black wire comes from the fuel pump relay, and the black/white and black [thats two wires] are the grounds.)
Use the following link: here. Look at my post (post #2) to test some stuff (as far as spark is concerned). NOTE: The test shown for the Automatic Shutdown Relay will work for the Fuel Pump relay as well (but only for those two)
I hope this applies to your truck. Let us know what happens.
__________________
If parts ain't flyin', you ain't tryin'.
1996 Dodge Dakota, 4x4, extended cab, 3.9L, automatic. - my baby
2012 VW Jetta Premium with Nav, 2.0L TDI diesel, 6-speed manual - the daily
Traded: 2009 Toyota Corolla S, 1.8L, 5-speed manual
Reply With Quote
  #5  
Old 06-14-2006, 01:49 PM
91dakota2wd 91dakota2wd is offline
Garage is empty, add now
 
Join Date: Feb 2006
Posts: 34
Default RE: 1990 3.9L won't start

Should ad some more information. The 3.9L engine has throttle body injection. I'm more used to S10 Chevys but the carb/injection looks similar to those. It has 2 black circular objects in the middle. The plastic gas tank has already been removed from the truck by previous owner. Is there a way to test the fuel pump with it already out of the truck? I don't get any voltage at the coil with the key in the run position. The battery is showing 12.6 volts. I have a 91 Dakota and borrowed the automatic shutdown relay from it and plugged it into the 1990 Dakota and still no voltage at the coil. That's if I plugged it into the right spot. My 90 Dakota has a couple of separte relays attached to the fender wall on the drivers side while my 91 Dakota has a black plastic box with several relays and a few fuses inside it.
Reply With Quote
  #6  
Old 06-14-2006, 11:09 PM
91dakota2wd 91dakota2wd is offline
Garage is empty, add now
 
Join Date: Feb 2006
Posts: 34
Default RE: 1990 3.9L won't start

I got it running today. The first thing I did was jack the back up so I could slide the gas tank under and then block the tank up enough to plug the wiring harness connector into it. Then I connected the battery back up and turned the key on but didn't hear the pump running. Before pulling the tank back out I checked out the relays. I have a 91 V6 stick that I drive and another 92 V6 auto for parts and both had different relay boxes on the drivers front fender under the hood. The relays had the same plug pattern as the 1990 however. Also one of the relays was missing on the 1990. the other one was attached to the fender wall with a screw. I took a pair of relays from the parts 92 and plugged them into the 90 and noticed for the first time the check engine light came on when I turned the key to the run position. Also I could hear the fuel pump run for a second or two. So I put 1 gal of gas of in the tank and tried to start it. It took off and ran. So I put the tank back on all the way, after putting new 1/4 and 5/16 inch fuel hoses on since the old ones were dried and cracked. Drove it around the yard a little and seems to run ok. I notice it has low oil pressure like my 1991. That must be normal for them, kind of like Ford 400M's. Thanks for all the tips and advice. LB
Reply With Quote
  #7  
Old 06-20-2006, 12:42 AM
91dakota2wd 91dakota2wd is offline
Garage is empty, add now
 
Join Date: Feb 2006
Posts: 34
Default RE: 1990 3.9L won't start

Well today it wouldn't start again. Didn't show the check engine light when turning the key to the on position. I swapped in some known good relays and still no go. Guess I didn't have the problem licked just yet,
Reply With Quote
Old 06-20-2006, 12:42 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 07:52 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2