Go Back   DodgeForum.com > Dodge SUVs > Dodge Durango > 1st Gen Durango
Sign in using an external account
Register Forgot Password?


1st Gen Durango 1998 - 2003 Durango's

No heat

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-11-2014, 08:01 AM
Tuffmudder1991's Avatar
Tuffmudder1991 Tuffmudder1991 is offline
Registered User
Garage is empty, add now
 
Join Date: Feb 2014
Posts: 5
Default No heat

I got a 1999 dodge Durango slt wit the 5.2l. I have no heat unless I turn the blower off or on lowest setting. I replaced the thermostat it has a new water pump and radiator as well as hoses. I don't have any leak in pressure, no puddle in passenger floor. It is in good range on mixture as well as coolant level. Any ideas?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 02-11-2014, 10:03 AM
dannyquest dannyquest is offline
Registered User
Garage is empty, add now
 
Join Date: Feb 2014
Posts: 2
Default

Start by flushing heater core with hose. There is a good video on youtube.
Reply With Quote
Old 02-11-2014, 10:03 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 09:32 AM.

Internet Brands, Inc.


Contact Details & Emails