99 Durango Blower Motor Not working - DodgeForum.com



1st Gen Durango 1998 - 2003 Durango's

99 Durango Blower Motor Not working

Reply
 
 
  #1  
Old 07-17-2006, 01:05 PM
jjw99durango
jjw99durango is offline
Thread Starter
 
Join Date: Jul 2006
Posts: 3
Default 99 Durango Blower Motor Not working

Hi all, I am new to the forum and experincing a front AC blower motor problem. I have seen several threads on 2001 models, but I am not sure if it the same on a 1999 model.

Here is the problem, the blower works intermittently at all speeds, then starts suging at a much lower speed speed by itself (was on high setting), then finally stops working completeley. Some times if I mess with the AC selector swith and go to vent then back to AC I can get it to work for a minute or two, then stops working. Latley it isd not working at all. I took it to the dealer last week and they want $600 plus parts. I have been hosed by these guys before and hope to do it myself. They claim it is the blower motor that went bad.

I can use some help takling this problem. The blower motor looks like a big deal to get to. ANy advise would help. I have checked all the fuses and relays already. All are okay.
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
LONEWOLF2007
2nd Gen Durango
5
12-06-2016 05:04 PM
davebenn52
1st Gen Durango
0
07-08-2015 12:48 AM
kassie78
Dodge Caravan
0
07-06-2015 11:23 PM
janicedauw
Dodge Caravan
1
07-04-2015 08:12 PM
jzimmerman809
1st Gen Durango
5
07-03-2015 06:26 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 06:07 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send