95 intrepid speedo issue - DodgeForum.com


1st Gen Intrepid 1993 through 1997 Intrepids

95 intrepid speedo issue

Reply
 
 
  #1  
Old 12-03-2011, 08:58 PM
Ram96360
Ram96360 is offline
Amateur
Thread Starter
 
Join Date: Apr 2007
Location:
Posts: 38
Default 95 intrepid speedo issue

Hello all

I recently bought a 95 intrepid froma friend of mine . the 3.3L in it has 221K miles on the clock, runs and drives great , only issue is the Speedo is Inop. the Odometer still works, the speedo needle is at the bottom of the speedo . when you turn on the key it moves up to the little peg on the cluster and just sits there. thinking it was the speed sensor I replaced it but didnt help. no other issues with the car , trans shifts like smooth butter, any ideas on what is up with my speedo ??
Reply With Quote
  #2  
Old 12-20-2016, 10:22 AM
Coleton Poole
Coleton Poole is offline
Registered User
 
Join Date: Dec 2016
Posts: 1
Default Fix

Since the odometer is workerin and speedo needle jumps a bit the speedo is fine due to using same motor. Take out the cluster, have to remove side fuse cover and headlight switch as well as middle vents, not a hard job. Then remove cluster screws. Quick fix, literally hold cluster in your hand and rotate the whole cluster slowly until speedo needle is sitting on the rest point instead of behind it. Permanent fix, disassemble cluster and use something to keep needle from going behind rest point. I would just put a small glob of hot glue at about 3/4 speedometer
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Strocket
1st Gen Durango
3
08-02-2015 06:20 PM
Mack8514
2nd Gen Dakota
9
07-19-2015 03:02 PM
JoshSlash87
3rd Gen Ram Tech
1
07-14-2015 08:51 AM
CharlesShaheen
2nd Gen Intrepid
0
07-11-2015 11:35 PM
Johnoolo
Dodge Neon
0
07-08-2015 11:10 AM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 02:00 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send