97 neon no spark - DodgeForum.com

Go Back   DodgeForum.com > Dodge Cars > Dodge Neon > 1st Gen Neon
Log In 


1st Gen Neon 1995 through 1999 Neons

All times are GMT -4. The time now is 08:16 PM.>

97 neon no spark

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-27-2013, 08:08 PM
Bobfrompa Bobfrompa is offline
Registered User
 
Join Date: Apr 2013
Posts: 4
Default 97 neon no spark

Ok here is the long and short of it : I bought a 97 neon dohc 2 door stick . Has no spark with the cam sensor plugged in and bolted on . If I remove it and crank it or unplug it , I get spark and rpm through a scanner . When the cam sensor is in correctly no rpm in scanner so spark ? Any ideas greatly appreciated . It has fuel to rail and I hear the asd working . Tried several used cam sensors . All of them will give me spark when unbolted from the head hanging loose .

Last edited by Bobfrompa; 04-27-2013 at 08:12 PM. Reason: Unclear wording
Reply With Quote
  #2  
Old 04-27-2013, 09:15 PM
I_Ride_Neon's Avatar
I_Ride_Neon I_Ride_Neon is offline
Record Breaker
 
Join Date: Nov 2007
Vehicle: 2003 Srt-4
Location: Dubuque, Iowa
Posts: 2,004
gurglingwhistle
Default

Make sure the timing belt isn't broken? Did you check the coil? If your getting an RPM reading with the cam sensor unhooked I assume its taking reference from the crank sensor or something. Does the cam magnet look okay? Did you check the crankshaft sensor at all? are you getting fuel to the rail?
__________________
92 Dodge Daytona Iroc R/T: Big turbo, 25psi on 92 octane

03 Neon Srt-4: 1025cc injectors on E85, 25psi spike on e85
Reply With Quote
  #3  
Old 04-27-2013, 09:44 PM
Bobfrompa Bobfrompa is offline
Registered User
 
Join Date: Apr 2013
Posts: 4
Default

The belt isn't broken . I tried two different cam magnets . Got fuel to the rail . I hear the fuel pump running . I checked the crank sensor by pulling it out and waving a screwdriver by it and got spark . And like is said if I unbolt the CPS from the head and let it hang I got good spark . But bolted up and cranking no spark . Could this be a timing relationship problem ? I'm gonna pull the bolt off the cam gear and check the key on the cam .
Reply With Quote
  #4  
Old 04-27-2013, 09:53 PM
I_Ride_Neon's Avatar
I_Ride_Neon I_Ride_Neon is offline
Record Breaker
 
Join Date: Nov 2007
Vehicle: 2003 Srt-4
Location: Dubuque, Iowa
Posts: 2,004
gurglingwhistle
Default

I would check the wiring if you lose spark when the cam sensor is on the motor. Something is fishy there. And yes they can be a timing related problem if the belt is broke or the dowel pin on the cam broke off. But if the camshaft is spinning then that's not your issue.
__________________
92 Dodge Daytona Iroc R/T: Big turbo, 25psi on 92 octane

03 Neon Srt-4: 1025cc injectors on E85, 25psi spike on e85
Reply With Quote
  #5  
Old 04-27-2013, 09:58 PM
Bobfrompa Bobfrompa is offline
Registered User
 
Join Date: Apr 2013
Posts: 4
Default

When I had the CPS off I could look and see the magnet on the cam spinning when I was cranking also . So I would say the cam isn't snapped or busted . I'll need to check the wiring next . This is really puzzling .
Reply With Quote
  #6  
Old 04-27-2013, 10:22 PM
I_Ride_Neon's Avatar
I_Ride_Neon I_Ride_Neon is offline
Record Breaker
 
Join Date: Nov 2007
Vehicle: 2003 Srt-4
Location: Dubuque, Iowa
Posts: 2,004
gurglingwhistle
Default

Yes I agree. Are you getting fuel when you don't get spark?
__________________
92 Dodge Daytona Iroc R/T: Big turbo, 25psi on 92 octane

03 Neon Srt-4: 1025cc injectors on E85, 25psi spike on e85
Reply With Quote
  #7  
Old 04-27-2013, 11:26 PM
Bobfrompa Bobfrompa is offline
Registered User
 
Join Date: Apr 2013
Posts: 4
Default

I'll check the fuel with or with out spark . I saw about the possibility of the vss shorting so that is disconnected .
Reply With Quote
 
 
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
going to go look at an 03 sxt tomorrow, what to look for? tom5170 Dodge Neon 3 08-25-2015 12:16 PM
Alternator is overcharging Jason Hartwick 1st Gen Neon 5 08-21-2015 08:28 PM
'89 Dakota - No spark ejpedde 1st Gen Dakota 8 08-19-2015 08:22 PM
Where can I buy the HVAC center bezel light bulbs? tmbouman 2nd Gen Neon 2 08-19-2015 01:42 PM
Wits end with no spark on 2.0 stratus sedan rdeyoe Dodge Stratus 1 08-16-2015 08:45 PM

 
Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

Internet Brands, Inc.


Contact Details & Emails