Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 1st Gen Ram Tech
Sign in using an external account
Register Forgot Password?


1st Gen Ram Tech '93 & older Rams: This section is for TECHNICAL discussions only, that involve 1993 Rams and older. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

1990 dodge d150 ignition problems

Reply
 
 
 
 
Thread Tools Search this Thread
  #21  
Old 09-23-2008, 12:01 AM
that_dodge_guy that_dodge_guy is offline
Registered User
 
Join Date: Sep 2008
Vehicle: 1990 Dodge D150 R/T Sport
Location: Barrie
Posts: 2
Default

i read all of this i have 1990 dodge d150 and all i have to say is how on earth did you get a computer in yours sounds impossible to me ive never seen or heard of that before
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #22  
Old 05-26-2013, 09:07 PM
mikehill2009's Avatar
mikehill2009 mikehill2009 is offline
Registered User
 
Join Date: May 2013
Posts: 6
Default

I'm having lots of problems with mine. I'm new to the forum and this is my first Dodge. I bought 1990 D150 for my son. Truck ran great, just smoked alot. Backed in the garage, took top end off, had the heads redone. Put it back together, no spark, no fuel. If I run a jumper from + side of Battery to + on the coil I can hear the fuel pump running, just cranks will not start. I can jump across the ASD relay and the pump runs, power to the + side of coil, still just cranks. I'm unable to turn the key for the codes because the check engine does not work, the bulb is fine. I put a new relay in still nothing. Parts store says a new hall effect is $80 and an ECM $220. I really don"t want to change parts based on a gues. I have now idea where to start. The only wiring that got disturbed was the harness that runs down the right side of the engine, wires for the Tbi, alternator, sensors on the intake and the distributor. Would appreciate some help.
Reply With Quote
  #23  
Old 05-26-2013, 09:24 PM
crazzywolfie's Avatar
crazzywolfie crazzywolfie is offline
Grand Champion
 
Join Date: Jun 2009
Vehicle: 91 & 81 d150 carburated 318's 93 R.C. F.I.318
Location: orangeville ontario
Posts: 6,780
Default

should really have started your own thread so people don't get confused by the 5 year old posts.

does everything else work? headlights, blower motor, wipers, stereo? have you checked your ground wires from the battery to the engine and engine to the body?
Reply With Quote
  #24  
Old 05-27-2013, 01:45 AM
mikehill2009's Avatar
mikehill2009 mikehill2009 is offline
Registered User
 
Join Date: May 2013
Posts: 6
Default

Sorry, it wont let me start a new one. Yes, everything else works fine. I found only two. The negative from the battery to front of the left head and rear of the right head to the firewall.
Reply With Quote
Old 05-27-2013, 01:45 AM
 
 
 
Reply




Tags
1990, 91, codes, crank, crankshaft, d150, dodge, ignition, needed, position, problem, replacing, sensor, trouble, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 10:23 AM.

Internet Brands, Inc.


Contact Details & Emails