Code P0051 - DodgeForum.com


2nd Gen Dakota 1997 - 2004 Dakota's

Code P0051

Reply
 
 
  #1  
Old 07-12-2014, 04:58 PM
daveespey
daveespey is offline
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 2
Default Code P0051

2001 Dakota 4.7 with A/C. One 02 sensor went out so I replaced them all. Now getting a Code: P0051 H02S Sensor Control Circuit Low (Bank 2 Sensor 1)


When driving with scanner on here is the data
Oxy Sensor 2 Bank 1 .660 V (some fluctuations)
Oxy Sensor 1 Bank 2 1.000 V (no fluctuations)
Oxy Sensor 1 Bank 1 .660 V (some fluctuations)
Oxy Sensor 2 Bank 2 .660 V (some fluctuations)


I have replaced Oxy Sensor 1 bank 2 twice now with factory parts and still throw the code.


question: is it possible my 02 Sensor Relay is going bad or is there a fuse somewhere that could be bad?


Thank you in advance!
Reply With Quote
  #2  
Old 07-12-2014, 05:22 PM
HeyYou's Avatar
HeyYou
HeyYou is online now
Super Moderator
 
Join Date: Apr 2010
Location: Clayton MI
Posts: 41,588
Default

Gonna move this to the 2nd gen dakota section for you. Welcome to DF!
Reply With Quote
  #3  
Old 07-12-2014, 08:22 PM
98DAKAZ's Avatar
98DAKAZ
98DAKAZ is offline
Champion
 
Join Date: Jul 2011
Location: Gilbert, Arizona
Posts: 4,344
Default

What brand did you buy? Bosch? The 4.7 runs bad with Bosch O2's
Reply With Quote
  #4  
Old 07-13-2014, 01:36 PM
daveespey
daveespey is offline
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 2
Default Code P0051

Replace all 4 02 sensors with OEM Denso brand.
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Gone Fishin
3rd Gen Ram Tech
1
07-05-2016 07:49 PM
Miketech137
Dodge Caravan
5
10-20-2015 07:27 PM
just1creation
Dodge Stratus
1
08-04-2015 11:05 AM
JoshuaYsassi
2nd Gen Ram Tech
21
07-28-2015 11:16 AM
Stratus0159
Dodge Stratus
2
07-16-2015 11:22 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 04:23 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send