Engine bogs and sputters - DodgeForum.com

Go Back   DodgeForum.com > Dodge Trucks > Dodge Dakota > 2nd Gen Dakota
Log In 

2nd Gen Dakota 1997 - 2004 Dakota's

Engine bogs and sputters

Thread Tools Search this Thread
Old 07-31-2014, 03:53 AM
PeteCelery PeteCelery is offline
Registered User
Join Date: Jul 2014
Posts: 1
Default Engine bogs and sputters

I'm sure this question has been asked before but I'm new to the forum and couldn't find it. I have a 2001 dakota with a 3.9 V6 with 110k my dad just gave me. When you're driving and give it gas it will spit and sputter and won't rev past 2000RPM while in drive. If you put it in nutarl and rev it it doesn't bog or anything. I can normally tell when it's going to do it cause when you stop at a light it will idle rough and at about 600-800. I've ran injector cleaner and premium fuel in it thinking it would help but it didn't really. If I drive it daily it gets better but when I let it sit for the weekend as I drive my nicer car it runs like **** monday. It throws codes once in a while and when it does it says its a O2 sensor. The last time codes came up it said there was a misfire in #1 and #3. It kinda sounds like it's backfiring too but not a loud bang like a normal backfire when it bogs. This wouldn't be a big problem but I drive on the highway and it does it sometimes as I'm getting on and I don't really feel like getting hit from behind because of a easy fix. Thanks in advance for reading and helping out if you can.
Reply With Quote
Old 07-31-2014, 09:33 AM
sxrsil3nt's Avatar
sxrsil3nt sxrsil3nt is offline
Record Breaker
Join Date: Dec 2010
Vehicle: 2002 Dodge Dakota Sport 4x4 3.9L
Location: Ontario, Canada
Posts: 1,075

Well yours is kind enough to throw a code... mine did the same thing (02 3.9) and it went on to be my bank 1 upstream sensor.

Search backfire from hell on these forums... I posted a video of the problem and you can hear it backfirih around the 3 man mark. See if its similar.
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 5.9L gas has spark and fuel but won't start herche54 2nd Gen Ram Tech 13 07-17-2015 05:38 PM
2007 hesitates while shifting at 80km/hr Rockymountain Dodge Nitro 1 07-15-2015 10:11 AM
P0700 notsofast 2nd Gen Durango 0 07-12-2015 07:37 PM
Can it run without a cat converter? smess 1st Gen Durango 3 07-08-2015 05:43 PM
FS[Engine/Transmission]: 5.2L Short Block w Listed Parts rampuppy User Classifieds 3 07-08-2015 04:10 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 02:28 PM.