Go Back   DodgeForum.com > Dodge SUVs > Dodge Durango > 2nd Gen Durango
Sign in using an external account
Register Forgot Password?


2nd Gen Durango 2004 - 2009

Front Blower not Working on 05 Durango

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-08-2009, 07:04 PM
mph62 mph62 is offline
Registered User
Garage is empty, add now
 
Join Date: Feb 2009
Posts: 1
Question Front Blower not Working on 05 Durango

My front blower for my heat/defrost went out on my 2005 Dodge Durango. The back works fine, but the front does not blow air. We located the blower resistor after reading the threads at this site. Upon inspection we found there was a burn spot on one wire and where it plugs into on the resistor. Will we need to replace the whole wire harness or just the resistor? Thank you for any help you can provide. mph62
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
Old 02-08-2009, 07:04 PM
Reply
 
 
 




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 06:41 PM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2