Go Back   DodgeForum.com > Dodge SUVs > Dodge Durango > 2nd Gen Durango
Sign in using an external account
Register Forgot Password?


2nd Gen Durango 2004 - 2009

Transmission issues PLEASE HELP

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-07-2013, 08:09 PM
lucas_gamboe lucas_gamboe is offline
Registered User
Garage is empty, add now
 
Join Date: Nov 2013
Posts: 1
Default Transmission issues PLEASE HELP

I have a 2004 Durango 5.7L Hemi Limited
4WD/AWD

58K Miles

Got into it very cheap because the previous owner I believe was worried about it throwing a rod. I've illiminated that threat thanks to a poster here who discovered it was the wiper cowl leaking water onto the intake. I took that a step further and used rubber grommets where the wiper arms connect and used clear silicone along all contact points and those push pins. (not a drop of water aside from what leaks thru the cabin filter blanket, if you have suggestions on that please offer them)

Anyway, I changed my transmission filter(both) and fluid a month ago for my 60K tune up along with plugs(copper).

It ran...different for a month and my MPG dropped by about 1mpg. I checked the dipstick and I had over filled by about 2.5 quarts. I drained some out and am now about 1 quart over. I'd go to the correct level but it already seems to be low. It is not leaking either

It has random shifts at hwy speed and at low speed seems to be revving too high. And does not have the same get up that it did before. MPGs are also way down. Was 22-24 HWY/16.9 average. Now 19-20 HWY/14-15 average.

Now...what I think may have happened. When replacing the filter, the metal ring did not come out with the old filter so I threw the new one out and assumed to old ring would work fine. Could I not have proper pressure? (maybe the old one fell out without knowing)

I'm thinking of doing it again, only this time paying attention.

Thanks guys
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
Old 11-07-2013, 08:09 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 12:09 PM.

Internet Brands, Inc.


Contact Details & Emails