2003 Dodge Neon SXT Total Electrical Failure - DodgeForum.com



2nd Gen Neon 2000 - 2005 2nd Gen Neon

2003 Dodge Neon SXT Total Electrical Failure

Reply
 
 
  #1  
Old 09-24-2009, 04:08 AM
DJMaxSmart86
DJMaxSmart86 is offline
Registered User
Thread Starter
 
Join Date: Jan 2006
Location: Syracuse, NY
Posts: 27
Default 2003 Dodge Neon SXT Total Electrical Failure

Hi,

I was driving my '03 Neon Sxt when the battery light came on.
I thought nothing of it until the check engine light and air bag light
came on as well. The car's automatic transmission would not shift like it was supposed to at higher rpm's either. Then my dashboard lights, and headlights grew dim and
the radio would not turn on. My turn signals or hazard lights would not work.
I took it to Auto Zone to have them hook their gizmo up to it and they could not even
get a code because the guy said the ECM didn't work. Luckily I hadn't turned the car
off and i made it to the dealer to drop the car off. I tried re-starting it but no luck.
Any idea what the hell could've caused this and was I right for thinking this was a dealer
issue? I've still got a couple thousand miles before my 80,000 mile powertrain warrantee is up. I'll have the car paid off by the beginning of November.
Should I keep the car after the dealer fixes it? Was this just a fluke electrical problem?
Reply With Quote
  #2  
Old 09-24-2009, 10:51 AM
srt4rez
srt4rez is offline
Professional
 
Join Date: Feb 2008
Location: Four Corners of AZ
Posts: 236
Default

Sounds to me like your alternator went out, if not check all your wirings that go to the charging system. Also check all your fuses too! Good luck!
Reply With Quote
  #3  
Old 09-24-2009, 03:36 PM
darthroush's Avatar
darthroush
darthroush is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Sep 2008
Location: People's Republic of Kalifornia
Posts: 5,478
Default

If you have a warranty still, use it. Save yourself the money and trouble of trying to fix it.
Reply With Quote
  #4  
Old 09-25-2009, 03:17 AM
neisg1
neisg1 is offline
Veteran
 
Join Date: Jan 2007
Location: Canada
Posts: 401
Default

I agree, either the alternator died and the battery went dead or the battery is totaly shot. If the voltage drops low enough the computer will reset and not show you any codes.
Reply With Quote
  #5  
Old 09-25-2009, 10:57 AM
srt4rez
srt4rez is offline
Professional
 
Join Date: Feb 2008
Location: Four Corners of AZ
Posts: 236
Default

Yes, check for the warranty and go from there.
Reply With Quote
  #6  
Old 09-25-2009, 01:22 PM
deranged's Avatar
deranged
deranged is offline
Record Breaker
 
Join Date: Nov 2005
Posts: 2,064
Default

I once had to drive our 02 Neon ES 60+ miles with a stone dead battery. Most of the same symptoms you describe but it shifted fine. The cooling fan still ran but every time it kicked on really weird stuff would go on with the gauges and you could tell the car wanted to quit running.
Reply With Quote
  #7  
Old 09-26-2009, 05:47 AM
DJMaxSmart86
DJMaxSmart86 is offline
Registered User
Thread Starter
 
Join Date: Jan 2006
Location: Syracuse, NY
Posts: 27
Default

Hi,

Thanx for the suggestions. It WAS the alternator and of course it wasn't
covered by my warrantee so I had to cough up almost $500 for the repair bill.
Reply With Quote
  #8  
Old 09-26-2009, 08:02 AM
deranged's Avatar
deranged
deranged is offline
Record Breaker
 
Join Date: Nov 2005
Posts: 2,064
Default

Owwwwwwwwwwww! That sucks!
Reply With Quote
  #9  
Old 12-21-2012, 07:10 PM
shana6977
shana6977 is offline
Registered User
 
Join Date: Dec 2012
Posts: 1
Unhappy 2003 Dodge Neon SXT PROBLEM! PLEASE HELP!

I have a 2003 dodge neon sxt i drove through a puddle 3 days ago and dash lights started all coming on one at a time (starting with battery light) the more lights that came on the ruffer the car started to run. Call husband because car was really running bad he told me to pull over turn it off and restart so i did Car wouldnt start So he came and gave me a jump car finally started take it straight home and park it he gets off work i go to leave go to store car started missing bad and die . have changed crank and cam sensors, coil, plugs, battery, and can now get it to start but at idel runs really ruff almost wanting to die, giving it gas it wants to sputter, trying to drive its lack of power giving gas. Car is manual. Can anyone please help?
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
john_2216
3rd Gen Ram Tech
6
11-09-2015 10:42 PM
sonnychi
Dodge/Ram Diesel
12
07-28-2015 01:53 AM
03Ram5.7
3rd Gen RAM general discussion/NON-tech
5
07-06-2015 06:41 PM
janicedauw
Dodge Caravan
1
07-04-2015 08:12 PM
RM-D150
1st Gen Ram Tech
1
07-04-2015 09:23 AM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 02:07 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send