Go Back   DodgeForum.com > Dodge Cars > Dodge Neon > 2nd Gen Neon
Sign in using an external account
Register Forgot Password?


2nd Gen Neon 2000 - 2005 2nd Gen Neon

2004 Dodge sx 2.0 problems

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-23-2010, 01:30 PM
Maxim Maxim is offline
Registered User
2004 Dodge Neon
 
Join Date: Dec 2010
Posts: 12
Exclamation 2004 Dodge sx 2.0 problems

Hi everyone, I have a 2004 dodge sx 2.0. I am still having vibration in my car after replacing transsmission mount, upper and lower troque strut mounts. I adjusted the torque struts to be 119 mm as I saw in the forum. The vibration happens while I am standing on park or drive. I can feel the vibration on the steering wheel and the left side of the car. Another problem is when I accelarate there is a squecky noise coming from the right passenger side. I just can't stand the vibration and all the money I spent on this car. I hope someone can give me some advice on how to fix the problems.

Thanks, Maxim
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 12-23-2010, 03:11 PM
darthroush's Avatar
darthroush darthroush is offline
Section Moderator
Dodge Forum Moderator
2003 Dodge Neon
 
Join Date: Sep 2008
Location: People's Republic of Kalifornia
Posts: 5,314
Default

Did you replace the motor mount?
__________________

Torque Strut Alignment Procedure | Maintenance Info | '00-'02 FSM | '03-'05 FSM | FAQ and Performance Thread

Please do not PM me questions about your Neon. Start a thread. Your questions will be answered quicker that way.
If you do PM me, expect a 1-2 week wait for a reply.
All FSM pictures, pages and information: 2003 DaimlerChrysler Corporation
Reply With Quote
  #3  
Old 12-23-2010, 04:32 PM
showsxt's Avatar
showsxt showsxt is offline
Record Breaker
2004 Dodge Neon
 
Join Date: Aug 2009
Vehicle: Dodge sxt
Location: Desmoines iowa
Posts: 1,147
Default

Theres one mrre mount which is the middle one and that was my problem after my husband changed the upper and lower ones. He checked the tranny mount and that was ok and the middle one was worn out so he changed that and no more vibrations and she was really quiet again and drives like new. Look at the one and see if thats your problem.
Reply With Quote
  #4  
Old 12-23-2010, 09:29 PM
Maxim Maxim is offline
Registered User
2004 Dodge Neon
 
Join Date: Dec 2010
Posts: 12
Default

I didn't replace the middle right mount. I am tired of wasting so much money on this car ;/. But, I guess I will have to replace it. It's 90$ + tax here in Toronto ;s
Can be the vibration of something like torque converter?
Reply With Quote
  #5  
Old 12-23-2010, 10:00 PM
hemi4spd's Avatar
hemi4spd hemi4spd is offline
All Star
Garage is empty, add now
 
Join Date: Aug 2010
Vehicle: '72 Swinger, '95 Dak, '94 Caravan, '96 Caravan, '00 caravan, '07 Gr. Caravan, '00 Neon
Location: Toronto Canada
Posts: 843
Default

the middle mount is one of the more important mounts, a little bit of a pian to replace but not impossible.
if the vibe was from the convertor(lets say it threw a balance weight off) you would feel the vibe all the time (PRNDL)
you say u only feel it in park and drive. so my guess is the convertor is fine.
I'm in Oshawa so hit me up if you need any help.
Reply With Quote
  #6  
Old 12-24-2010, 09:28 AM
showsxt's Avatar
showsxt showsxt is offline
Record Breaker
2004 Dodge Neon
 
Join Date: Aug 2009
Vehicle: Dodge sxt
Location: Desmoines iowa
Posts: 1,147
Default

Yep its the middle mount I had the same vibration in my 04 sxt when driving and when I was in park. So change that and your sx will be back to normal. You should try a junk yard and see if you can find a 05 sx . I found a 05 sxt and the mount was only like 45 to 50 bucks if I remember right and was like new.
Reply With Quote
  #7  
Old 02-10-2011, 09:08 PM
Maxim Maxim is offline
Registered User
2004 Dodge Neon
 
Join Date: Dec 2010
Posts: 12
Default

So, after replacing the middle mount... I still have some vibration/rattling noise when I am accelerating on low rpm or when the transmission shifts gear down when I press the brake... I've replaced all of the mounts. What can it be? I guess the adjustment may be wrong... please help because this is really annoying me =/! Thanks
Reply With Quote
  #8  
Old 02-10-2011, 09:10 PM
showsxt's Avatar
showsxt showsxt is offline
Record Breaker
2004 Dodge Neon
 
Join Date: Aug 2009
Vehicle: Dodge sxt
Location: Desmoines iowa
Posts: 1,147
Default

Yeah you might want to check the adjustment seeing after my husband changed mine dont have vibrations anymore.
Reply With Quote
  #9  
Old 02-10-2011, 09:21 PM
Maxim Maxim is offline
Registered User
2004 Dodge Neon
 
Join Date: Dec 2010
Posts: 12
Default

The problem is I don't have the tools for it and I am not experienced with fixing cars by my self. I am steel a student lol. My uncle was the one who was helping with all my repairs and I don't want to ask my uncle to do that because he just hates this car. He spend so much time fixing it lol. We changed the engine and the motor mounts slowly one by one. So I have to figure out something... because this vibration is annoying me badly. Its much less than before but you can still feel it. You can feel your butt vibrating. In other cars you feel much less vibration, but don't know about other neons. I guess need to figure out something.... Maybe need to get tools and try to do the adjustment by myself. Thanks anyways for advice
Reply With Quote
  #10  
Old 02-10-2011, 09:45 PM
showsxt's Avatar
showsxt showsxt is offline
Record Breaker
2004 Dodge Neon
 
Join Date: Aug 2009
Vehicle: Dodge sxt
Location: Desmoines iowa
Posts: 1,147
Default

Your uncle sounds like mine over the yrs he has helped me with all my neons and hes sick of them. Hope you fix the problem.
Reply With Quote
Old 02-10-2011, 09:45 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 12:48 AM.

Internet Brands, Inc.


Contact Details & Emails