Help! P0340 Cam Sensor Troubles 05 Neon - DodgeForum.com



2nd Gen Neon 2000 - 2005 2nd Gen Neon

Help! P0340 Cam Sensor Troubles 05 Neon

Reply
 
 
  #1  
Old 05-13-2011, 12:13 PM
jonnybegoode18
jonnybegoode18 is offline
Registered User
Thread Starter
 
Join Date: May 2011
Posts: 1
Default Help! P0340 Cam Sensor Troubles 05 Neon

Backround, For about 6 months my girlfriends car, 2005 Dodge Neon SXT 2.0, has occasionally began to stutter and not rev past 4k rpm. Usually just shut down and restart a few mins later and problem gone. This would happen every 2 or 3 weeks.

In and effort to fix this myself due to extremely low funds, over time I have replaced the battery, all spark plugs, all spark plug wires, stp gas adders etc etc. The problem would go away but always come back a few weeks later.


Recently I found out how to read the OBD codes myself, got codes 301 304 and 340, misfires piston 1 and 4 and Cam sensor troubles. I have replaced the cam sensor and now it has trouble starting and will not rev past about 2200 rpm. again giving the p0340 code

Please HELP! What other things can this be??
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stonernate
Dodge Neon
1
02-07-2016 05:02 PM
95Ram2500v10
2nd Gen Ram Tech
5
02-01-2016 12:09 AM
gpaulino
2nd Gen Neon
1
09-06-2015 05:23 PM
iminlovewithmopar
Dodge Neon
0
07-15-2015 09:34 PM
colons3499
Dodge Neon
0
07-09-2015 04:57 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 04:01 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send