Go Back   DodgeForum.com > Dodge Cars > Dodge Neon > 2nd Gen Neon
Sign in using an external account
Register Forgot Password?


2nd Gen Neon 2000 - 2005 2nd Gen Neon

Car alarm goes off everytime I try to start my car

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-08-2014, 01:16 AM
t480 t480 is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2010
Posts: 20
Default Car alarm goes off everytime I try to start my car

Dodge Neon 2005

My alarm remote will allow me to open my door, but when I put my key in the ignition, my alarm goes off and my car wont start. its like my car thinks its being stolen

any idea whats going on?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 06-08-2014, 12:31 PM
t480 t480 is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2010
Posts: 20
Default

Ok. Day after. Car still won't start but atleast I don't hear an alarm. I have dash lights etc. Automatic doors slow to open. Probably Battery?
Reply With Quote
  #3  
Old 06-08-2014, 01:11 PM
darthroush's Avatar
darthroush darthroush is offline
Section Moderator
Dodge Forum Moderator
2003 Dodge Neon
 
Join Date: Sep 2008
Location: People's Republic of Kalifornia
Posts: 5,305
Default

Does the car make a click, click, click sound when you are trying to start it, or nothing? Either way, battery checks/tests are free at parts stores
__________________

Torque Strut Alignment Procedure | Maintenance Info | '00-'02 FSM | '03-'05 FSM | FAQ and Performance Thread

Please do not PM me questions about your Neon. Start a thread. Your questions will be answered quicker that way.
If you do PM me, expect a 1-2 week wait for a reply.
All FSM pictures, pages and information: 2003 DaimlerChrysler Corporation
Reply With Quote
  #4  
Old 06-08-2014, 04:32 PM
t480 t480 is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2010
Posts: 20
Default

No clicking. But I know what steps to follow as the situation is now. I just don't know what was up with the alarm
Reply With Quote
  #5  
Old 06-08-2014, 11:46 PM
t480 t480 is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2010
Posts: 20
Default

Ok, so my battery is fine. I, until I get this fixed, just need to press the button behind the red flashing light under my dash to deactivate my alarm so my car starts. kinda a hassle but atleast I can drive my car.
Reply With Quote
Old 06-08-2014, 11:46 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 04:26 PM.

Internet Brands, Inc.


Contact Details & Emails