05 neon - DodgeForum.com


2nd Gen Neon 2000 - 2005 2nd Gen Neon

05 neon

Reply
 
 
  #1  
Old 02-26-2017, 12:29 PM
Shall1331
Shall1331 is offline
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 1
Default 05 neon

I have a 05 neon sxt? (previous owner(s) converted exterior to appear as a srt4) so I pulled in my driveway after work Friday and the car went to half power. Plugged in the reader after she stopped dead, got p2305 ign cool b secondary ckt p0508 idle Intel system ckt low and p0038 Ho2s 1/2 heaster cut high. Now I already new my MAF was funky, figured it was cause my k&n filter was dirty. So I cleaned the sensor with carb cleaner multiple times. Still ran the same. I let her sit for a day and now it's running like nothing happened no codes or anything. Any suggestions??
PS I already have a brand new 9cm.

Any help would be greatly appreciated!
Reply With Quote
  #2  
Old 03-02-2017, 02:23 AM
paw paw
paw paw is offline
Professional
 
Join Date: Jul 2016
Location: SW Va
Posts: 120
Default

Welcome to the 2nd gen Neon forum.

Electrical connection problem maybe, so when its running & warmed up like the time of the problem, raise the hood & begin a wiring wiggle test, especially where the computer electrical connections are made & along any runs on the engine where they see heat, vibration, engine torque movement, to see if you can induce the problem.
Let us know what you find.
Reply With Quote
 
 
Reply


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 06:02 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send