No power runs rough misfire 03 neon sxt - DodgeForum.com


2nd Gen Neon 2000 - 2005 2nd Gen Neon

No power runs rough misfire 03 neon sxt

Reply
 
 
  #1  
Old 05-14-2006, 10:48 PM
porovich
porovich is offline
Thread Starter
 
Join Date: May 2006
Posts: 5
Default No power runs rough misfire 03 neon sxt

My 03 neon sxt runs like crap It has absolutely no power runs rough misfires I changed the spark plugs and it ran good for 1 day I also changed the air filter It stalls shudders and sometimes dies Help
Reply With Quote
  #2  
Old 05-14-2006, 10:50 PM
leadspud
leadspud is offline
Professional
 
Join Date: Jan 2006
Location:
Posts: 202
Default RE: No power runs rough misfire 03 neon sxt

coil or plug wires? Do you have any codes
Reply With Quote
  #3  
Old 05-14-2006, 10:59 PM
porovich
porovich is offline
Thread Starter
 
Join Date: May 2006
Posts: 5
Default RE: No power runs rough misfire 03 neon sxt

P0340 P0440 P0038
Reply With Quote
  #4  
Old 05-14-2006, 11:57 PM
ewetho
ewetho is offline
All Star
 
Join Date: Nov 2004
Location: Kankakee, IL
Posts: 951
Default RE: No power runs rough misfire 03 neon sxt

Check them out in order. Solve the first code out first always. So you have a CAM sensor Circuit problem. Check make sure you cam sensor is plugged in and then probably time to replace it. Clear codes and go on.
Reply With Quote
  #5  
Old 05-15-2006, 12:16 AM
porovich
porovich is offline
Thread Starter
 
Join Date: May 2006
Posts: 5
Default RE: No power runs rough misfire 03 neon sxt

where is the cam sensor on the car
Reply With Quote
  #6  
Old 05-15-2006, 07:22 PM
2007CustomCaliber
2007CustomCaliber is offline
Rookie
 
Join Date: Apr 2005
Location:
Posts: 77
Default RE: No power runs rough misfire 03 neon sxt

my 2000 had misfire problems and it turned out to be the wires
Reply With Quote
  #7  
Old 05-16-2006, 04:08 PM
tooslow
tooslow is offline
Veteran
 
Join Date: Dec 2005
Location:
Posts: 457
Default RE: No power runs rough misfire 03 neon sxt

the cam sensor
on the driver side of the head it you have too move the wiring harnes and all those hoses too get too it
Reply With Quote
  #8  
Old 05-16-2006, 06:57 PM
flamingpinhead's Avatar
flamingpinhead
flamingpinhead is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2006
Location: Pennsylvania
Posts: 4,505
Default RE: No power runs rough misfire 03 neon sxt

first, try plugs & wires and coil.

edit:
when my srt had some rough running problems, it would run rough, lost power and would cut the rpms and sometimes overrev the motor without hitting the gas. it turns out the throttle positioning sensor was out of range, so the car's computer got 'confused'
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
95Ram2500v10
2nd Gen Ram Tech
5
01-31-2016 11:09 PM
Crytot
1st Gen Dakota
5
07-13-2015 05:26 PM
smess
1st Gen Durango
3
07-08-2015 04:43 PM
pilotforlife
Dodge Stratus
3
07-08-2015 10:35 AM
Johnoolo
Dodge Neon
0
07-08-2015 10:10 AM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 12:28 PM.