Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Turn Signals, Hazards, Brake Lights not working

Reply
 
 
 
 
Thread Tools Search this Thread
  #11  
Old 12-10-2011, 10:55 AM
zman17's Avatar
zman17 zman17 is offline
Section Moderator
Dodge Forum Moderator
2000 Dodge Ram 2500
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default

Seems like a ground problem. Check trailer wiring harness if you have one. Also I suggest buying a Haynes manual. It has wire schematics in it, so you can trace the grounds.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
Reply With Quote
  #12  
Old 04-08-2012, 01:15 PM
Mastodon Mastodon is offline
Registered User
1996 Dodge Ram 2500
 
Join Date: Apr 2012
Posts: 3
Default

Are there any solutions to this problem I am having the EXACT same issue, I have REAR lights that work but that is it, NO Reverse NO Signals NO Brakes, I tested the 5 pin tow package and its getting Brake lights Rear Lights and Reverse but no hazards or signals. Any ideas?
Reply With Quote
  #13  
Old 04-08-2012, 01:19 PM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
Garage is empty, add now
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 32,279
Default

Make sure the bulbs are good.... do any of the front lights work? (turn signals/hazards) Also check grounds.
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #14  
Old 04-09-2012, 08:10 AM
SoGone12 SoGone12 is offline
Registered User
Garage is empty, add now
 
Join Date: Dec 2011
Posts: 2
Default

Quote:
Originally Posted by Mastodon View Post
Are there any solutions to this problem I am having the EXACT same issue, I have REAR lights that work but that is it, NO Reverse NO Signals NO Brakes, I tested the 5 pin tow package and its getting Brake lights Rear Lights and Reverse but no hazards or signals. Any ideas?
I got my lights to all work by checking the wiring harness behind the wheel well on the drivers side. You don't need to but if you jack it up and take off the drivers side wheel you will see a small trap door panel close to the bottom of the wheel well. Behind it is the harness that connects your rear lighting system. Mine was all frayed and making little to no connections. I have a 1998 Dakota v6 3.9l.
Reply With Quote
  #15  
Old 04-09-2012, 12:31 PM
Mastodon Mastodon is offline
Registered User
1996 Dodge Ram 2500
 
Join Date: Apr 2012
Posts: 3
Default Still stumped

I tried to follow the wires all the way to the lights, and other than behind the tank I was unable to see any issues. I did notice that my hasard light fuse in the engine compartment fuse box is NOT getting power, good fuse but no power could this explain all of my issues? If so what would you suggest?

So as of now
-NO Turn signals (not even a ticker sound on the dash)
-NO Reverse Lights
-NO Brake Lights

Working
-Headlights
-Tailights
-Trailer Brake Lights
Reply With Quote
  #16  
Old 04-09-2012, 12:36 PM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
Garage is empty, add now
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 32,279
Default

Pull the covers off the column, and see if you aren't having some issues in there. If you have tilt wheel, the wires like to pull out of the connector... and things stop working.

Also, you probably have two separate problems there..... (brake/turn, and reverse lights.)
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #17  
Old 04-16-2012, 05:57 PM
Purple97Ram Purple97Ram is offline
Registered User
1972 Dodge Pickup
My Garage
 
Join Date: Apr 2012
Vehicle: 1997 Dodge Ram 1500 Laramie SLT
Location: Tallahassee, FL
Posts: 4
Default

I am having the same problems on my 97 1500. Third brake light, backup lights, and taillights work but main brake lights, hazards and turn signals don't. All front-end light functions are working. After reading some threads and looking at the diagrams in my Haynes Manuel, I decided to try the multifunction switch, brake switch, and headlight switch from the junk yard with no improvement. I even checked both multifunction switches for continuity and my old one had a problem with #11. I have the factory tow pkg so I thought that might eliminate a hack job but I have not checked the ground. I just sign up here so I am a newbie but I have been trying to read different threads for a while and it seems there could be a few different culprits here.
Reply With Quote
  #18  
Old 04-16-2012, 06:00 PM
Purple97Ram Purple97Ram is offline
Registered User
1972 Dodge Pickup
My Garage
 
Join Date: Apr 2012
Vehicle: 1997 Dodge Ram 1500 Laramie SLT
Location: Tallahassee, FL
Posts: 4
Default

Also, when I tilted the wheel all the way down to take off the shrouds it stuck there, anyone know how to unstick it? Do I have to take off the ignition switch? I did the same thing to the 95 1500 in the junk yard, oops.
Reply With Quote
  #19  
Old 04-16-2012, 06:45 PM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
Garage is empty, add now
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 32,279
Default

Stuck there? As in, won't turn, or, you can't tilt it back up?? Should be able to just pull the release lever, and it should come right back up..... should....

Check where the trailer harness hits the rear harness.... (trace if from the plug back to find where they link.) Known problem area on these trucks.
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #20  
Old 04-17-2012, 05:22 PM
Purple97Ram Purple97Ram is offline
Registered User
1972 Dodge Pickup
My Garage
 
Join Date: Apr 2012
Vehicle: 1997 Dodge Ram 1500 Laramie SLT
Location: Tallahassee, FL
Posts: 4
Default

Yea, it turns fine it is just stuck in the down position. I can move the tilt lever but it does not want to release. The funny thing is the fact I did the same thing to the one in the junkyard. If it hadn't started raining I would have experimented with it a while.

I'll check out the harness when I can this week and post what I find. Thanks!
Reply With Quote
Old 04-17-2012, 05:22 PM
 
 
 
Reply




Tags
2000, 2001, 94, blinkers, brake, caravan, dodge, flasher, gt, hazard, lights, mustang, signal, signals, sprinter, turn, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 09:10 PM.

Internet Brands, Inc.


Contact Details & Emails