Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

1997 Dodge Ram 1500 Transmission Shift Problems!!!

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-19-2010, 09:18 AM
KINGSOVEREIGN KINGSOVEREIGN is offline
Registered User
 
Join Date: Dec 2010
Posts: 1
Default 1997 Dodge Ram 1500 Transmission Shift Problems!!!

I have a 1997 Dodge Ram 1500 (Vin: Y) w/ 318 engine. And I've searched the forums and i can't seem to find the answer(s) to my question, so here goes:

It has like 105,000mi on it. And when I'm driving down the road it takes a little pedal easing to shift into 2nd gear and then i have to rev the engine up to like 3500+ rpm in order for it to shift into 3rd and 4th gear. I took it to the local Jiffy Lube to have it flushed and i put some Lucas in it thinking that would fix the problem but that doesn't seem to have done the trick. No such luck. It still doesn't like to shift into 3rd and 4th gear. Sometimes it still won't shift when i rev it to 4,000 rpm.

Any ideas? I heard people hinting at shift solenoids, and others hinting at a clogged transmission filter being the culprit. but i don't have the money to take it to a shop to figure it out.

Any suggestion would be much appreciated!
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 12-19-2010, 09:38 AM
HeyYou's Avatar
HeyYou HeyYou is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 32,681
Default

What does your fluid look like? Is the level up to snuff? (gotta check it in Neutral....) Take it for a drive, get everything nice and warm, block the wheels, or, set the e-brake, put it in neutral, and check the fluid.

If that looks ok, grab yourself a filter and gasket kit, and six quarts of ATF +4. Drop the pan, and while you are in there, have a look at the governor pressure sensor, and solenoid. Clean them out, or replace them.... adjust bands, and reassemble. See if that improves its attitude any. If it doesn't.... start saving your pennies for the trans rebuild.

Welcome to DF.
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #3  
Old 12-19-2010, 12:44 PM
matty675's Avatar
matty675 matty675 is offline
Record Breaker
 
Join Date: Feb 2010
Vehicle: 1997 Ram 1500
Location: Chesapeake, VA
Posts: 1,504
Default

you could also check the TV cable. return spring on the shift lever could be gone.

after TV adjustment and new governor pressure sensor and solenoid, mine shifts like a dream
__________________
FORD RACING INJECTORS FOR SALE
1997 Dodge Ram 1500 4x4 SLT Laramie CCSB
5.9L Magnum (408 build in the works )
Reply With Quote
  #4  
Old 06-29-2011, 04:49 PM
Ram4x45.9 Ram4x45.9 is offline
Registered User
 
Join Date: Dec 2010
Posts: 14
Default 46re tranny problem

I have a 1997 ram 2500 5.9 gas 46re tranny. I put a supperior shift kit in it.I have a new problem sometimes when i try to put in drive it wont go
somethings holding the shifter back then i push on the gas pedal and it wont go down when i push harder the gas pedal kindof pops and goes down and the tranny goes into drive. Sometimes when i push on gas pedal the tranny pops out of drive into neutral.What do you think about this?
I think the tv valve cable is interfearing with the shift linkage.
Reply With Quote
  #5  
Old 06-29-2011, 05:32 PM
umbali umbali is offline
Registered User
 
Join Date: Jun 2011
Posts: 16
Default

His issues sound very similar to mine, cept mine is a 95 without the electronics.

Is there something similar i can do that could possibly fix my issues? Bands ( how do you adjust them? ) Filter should be new since I got fluid changed 2 weeks ago.
__________________
1995 Dodge Ram 4x4 5.9L
Reply With Quote
  #6  
Old 06-29-2011, 06:14 PM
zman17's Avatar
zman17 zman17 is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default

Quote:
Originally Posted by Ram4x45.9 View Post
I have a 1997 ram 2500 5.9 gas 46re tranny. I put a supperior shift kit in it.I have a new problem sometimes when i try to put in drive it wont go
somethings holding the shifter back then i push on the gas pedal and it wont go down when i push harder the gas pedal kindof pops and goes down and the tranny goes into drive. Sometimes when i push on gas pedal the tranny pops out of drive into neutral.What do you think about this?
I think the tv valve cable is interfearing with the shift linkage.
Make sure the TV cable is free and not binding. Also make sure the spring is on the end of it down at the tranny.
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
Reply With Quote
  #7  
Old 06-29-2011, 07:21 PM
garam's Avatar
garam garam is offline
Professional
 
Join Date: May 2011
Vehicle: A 1999 Dodge Ram 1500 4X4 5.9L club cab.
Location: GA
Posts: 103
Default

These issues sounds like a combination of the problems we had on this thread. http://dodgeforum.com/forum/2nd-gen-...o-stay-in.html

Cleaning the IAC and throttle body appeared to do the trick for us. We also did a complete tune up and replaced some sensors. But the IAC and throttle body cleaning made the biggest improvement.

So in addition to checking the fluid, like HeyYou said, get a ~$1.50 throttle body gasket, throttle body cleaner (~ $3 to $4) and clean them real well. Then do the tune up and sensor replacements if needed.

And by all means try some of the other suggestions too, these guys appear to know these trucks. If it hadn't been for them and this forum I'd probably still be walking.

Last edited by garam; 06-29-2011 at 07:25 PM..
Reply With Quote
  #8  
Old 06-30-2011, 11:49 PM
Ram4x45.9 Ram4x45.9 is offline
Registered User
 
Join Date: Dec 2010
Posts: 14
Default

Ok i cralwed under the truck and found the bracket the the spring and tv cable hook to and fits on the shaft that goes in the valve body had poped off. I had tighten the bolt but its bottomed out. I'm going to put something around the shaft.Somebody on here said the spring might be off and they were right on the money.Thanks for the help!
Reply With Quote
  #9  
Old 09-25-2011, 12:53 AM
sawgunner sawgunner is offline
Registered User
 
Join Date: Sep 2011
Posts: 1
Default stuck in high gear

i have a ram 1500 4x4 when i put it in drive and take off it feels like its stuck in maybe third gear, takes alot of pedel to get it moving at first but when you get up around fourty it seems normal any faster it still will not shift and rpm's keep climbing. had it put on a scanner and od is out, can anyone tell me will that cause this problem and how can i fix it
Reply With Quote
  #10  
Old 09-25-2011, 01:33 AM
master tech's Avatar
master tech master tech is offline
Multi-section Moderator
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,611
Leonard Pierce
Default

KINGOVEREIGN

Your problem is a classic problem, What happens over time the transmission fluid gets hot and cause's the seals to get hard. This cause's the transmission to loose fluid pressure until you able build up enough pressure and by then you are doing 40 to 50 mph in 2nd gear. The fix is install a transmission seal kit.
__________________
Dodge Master Tech.
Reply With Quote
Old 09-25-2011, 01:33 AM
 
 
 
Reply




Tags
ram, ram 1500, shift, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 10:49 PM.

Internet Brands, Inc.


Contact Details & Emails