help!! I'm confused, what's wrong with my truck? -

Go Back > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Log In 

2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

help!! I'm confused, what's wrong with my truck?

Thread Tools Search this Thread
Old 06-10-2011, 07:07 PM
cowgirljenn cowgirljenn is offline
Registered User
Join Date: Apr 2011
Posts: 5
Unhappy help!! I'm confused, what's wrong with my truck?

i had replaced the alternator in my truck and the serpentine belt.... as soon as i started right after i got the belt on it it squeals bad and can smell burning rubber.. the belt is really tight and as soon as we start the truck i notice the tensioner will move a little bit... does anyone have any suggestions as to what is wrong with it this time??? PLEASE HELP I WANT TO DRIVE MY TRUCK
Attached Thumbnails
help!! I'm confused, what's wrong with my truck?-photo-0056-640x480-635x425-635x425-.jpg  
Cowgirl Jenn's Big Red Truck!
Reply With Quote
Old 06-10-2011, 07:20 PM
drewactual's Avatar
drewactual drewactual is offline
Join Date: Aug 2010
Vehicle: '02 1500 5.9L Magnum
Location: Cape Carteret NC
Posts: 2,698

are you certain you have it routed correctly? are you sure you have the right grooved belt?

you may need to start it BRIEFLY with the hood up and someone watching... just long enough to inspect each pulley and make sure they're rolling..

when what is happening to you happens, it's been my experience I routed teh belt wrong, or one of the pulleys is frozen..
'02 1500 4x4, 5.9L Magnum, 1.7 RR's, SCT, Hedman Headers, efan,,Air-Gap, true duals, 52mm TB, 4.56:1 Motive R&P's factory LSD..

Reply With Quote
Old 06-10-2011, 07:21 PM
dodgeram07's Avatar
dodgeram07 dodgeram07 is offline
Join Date: Mar 2008
Vehicle: 1995 ram 1500 5.2 2wd slt ext cab
Location: ohio
Posts: 3,363

is the alternator spings free lee? also are the other?
Reply With Quote
Old 06-10-2011, 07:27 PM
jasonw's Avatar
jasonw jasonw is offline
Site Moderator
Dodge Forum Moderator
Join Date: Jan 2008
Vehicle: 2013 Ram 1500 4X4
Location: Sioux Falls, SD
Posts: 8,303

Since this is a tech question, moved it to the main section. Should get more help that way.
Reply With Quote
Old 06-10-2011, 09:35 PM
97tn4x4 97tn4x4 is offline
Record Breaker
Join Date: Mar 2009
Vehicle: 1997 qcsb 1500 4x4
Location: Memphis, TN
Posts: 1,814

The tensioner will move some, that's ok. I'm with everyone else, check the routing of the belt. Pull it back off and check each pulley too while you're at it.
Reply With Quote
Old 06-11-2011, 02:31 AM
Sheriff420's Avatar
Sheriff420 Sheriff420 is offline
Grand Champion
Join Date: Apr 2008
Vehicle: 2000 Dodge Ram 1500 4x4 5.2
Location: Lee County, North Carolina
Posts: 6,863
Send a message via AIM to Sheriff420

Double check the part number for the belt or match it to the old one to make sure it's the right belt.

Airgap. HS 1.7s. 50mm DIY TB. Superchips 3815. 14x2 K&N round air filter. 4.10 Yukon gears. Detroit Truetrac-both axles. Front hitch. Rear hitch lights with skid plates. Westin nerf bars. 33" Nitto Terra Grappler G2 tires.
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
My ram truck Khris1994 2nd Gen Ram Tech 121 10-24-2015 03:47 PM
Coolant in oil, oil not in coolant. SteveTangential 1st Gen Ram Tech 4 09-10-2015 11:38 AM
1995 Dodge Ram 1500 5.9L 4x4 JoshuaYsassi 2nd Gen Ram Tech 63 07-24-2015 01:14 AM
tach runs in reverse tmomeik Dodge Stratus 5 07-05-2015 06:16 PM
Air Conditioning Issue kenm78 4th Gen Ram Tech 1 07-05-2015 03:05 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 06:21 PM.