Rebuilt RWAL valve - DodgeForum.com


2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Rebuilt RWAL valve

Reply
 
 
  #1  
Old 07-31-2012, 02:32 PM
turbogrampa
turbogrampa is offline
Registered User
Thread Starter
 
Join Date: Apr 2012
Posts: 4
Unhappy Rebuilt RWAL valve

Anyone know where I can get a rebuilt RWAL valve for my 96 2500 4x4.Code is blinking 2 on the ABS box and I have tried two used from the bone yard with no luck.Truck only has rear brakes in a panic stop.
Reply With Quote
  #2  
Old 07-31-2012, 02:35 PM
Wh1t3NuKle's Avatar
Wh1t3NuKle
Wh1t3NuKle is offline
Champion
 
Join Date: Sep 2011
Location: NorCal
Posts: 3,854
Default

I haven't looked at the actual code for this and I'm sure others have had some similar experiences with the awesome ABS in our trucks, but are you sure its the valve? Bunch of other things can throw ABS code (e.g., speed sensor in rear diff).
Reply With Quote
  #3  
Old 07-31-2012, 03:04 PM
billcart's Avatar
billcart
billcart is offline
Professional
 
Join Date: Aug 2010
Location: Corpus Christi, TX
Posts: 204
Default

RWAL sensor in the diff is problematic at times. Do you have 4 wheel or two wheel antilock? Easy way to tell is check the front brakes to see if you have wires going there. If so it is 4 wheel. If not then you have 2 wheel. Another thing to check is the brake pedal switch. If you have 4 wheel antilock then check the wires in the front for damage.
Reply With Quote
  #4  
Old 07-31-2012, 03:25 PM
turbogrampa
turbogrampa is offline
Registered User
Thread Starter
 
Join Date: Apr 2012
Posts: 4
Default

I have ONLY rear wheel ABS.I also have the factory repair manual and ran all the diag. and came up with this noaccount valve.
This is a 96 2500 4x4 with all new calipers discs,brake shoes and wheel cyl. as well as a new speed sensor in the rear and a new master cyl. Not much else left.
Also ckd. voltage off the sensor @factory specs,replaced Abs Controller,bleed the whole system with no luck. Then had the system power bled just to make sure,no help!~!

Last edited by turbogrampa; 07-31-2012 at 03:41 PM. Reason: Add content.
Reply With Quote
  #5  
Old 07-31-2012, 04:21 PM
billcart's Avatar
billcart
billcart is offline
Professional
 
Join Date: Aug 2010
Location: Corpus Christi, TX
Posts: 204
Default

Try putting on the old controller and disconnecting the battery for awhile and then reconnecting it. If that doesn't work then put the new back on take it to the dealership and verify that the system is working and doesn't need to be reprogrammed.
Reply With Quote
  #6  
Old 08-01-2012, 12:34 PM
turbogrampa
turbogrampa is offline
Registered User
Thread Starter
 
Join Date: Apr 2012
Posts: 4
Default

BillCart Thanks . That is a new take on the problem.I will try the exchange and see what happens.As for the dealer I don't know.They usually sock me a pretty penny to do anything.
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Relsom
2nd Gen Ram Tech
4
09-12-2015 12:53 PM
jeff351
2nd Gen Ram Tech
10
09-11-2015 09:16 AM
95DodgeNeon
Dodge Stratus
2
09-03-2015 05:56 PM
richardski
1st Gen Durango
1
09-01-2015 05:27 PM
jamesnb
2nd Gen Ram Tech
2
09-01-2015 12:42 AM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 08:31 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send