Battery light on - DodgeForum.com

Go Back   DodgeForum.com > Dodge SUVs > Dodge Durango > 3rd Gen Durango
Log In 


3rd Gen Durango 2011 models

Battery light on

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-22-2012, 07:15 PM
crew man crew man is offline
Amateur
 
Join Date: Feb 2012
Posts: 28
Default Battery light on

Heading to the dealership tomorrow with the battery light on. My 2012 Crew AWD V-6 is only a month old with 1000 miles. Hopefully something simple....Anyone else with this issue ? I'll update as to what they find out...
Reply With Quote
  #2  
Old 04-23-2012, 05:05 PM
DodgeCares's Avatar
DodgeCares DodgeCares is offline
Record Breaker
 
Join Date: Jul 2011
Location: Mopar HQ
Posts: 2,076
Default

Quote:
Originally Posted by crew man View Post
Heading to the dealership tomorrow with the battery light on. My 2012 Crew AWD V-6 is only a month old with 1000 miles. Hopefully something simple....Anyone else with this issue ? I'll update as to what they find out...
Crew,

Not sure what radio you have but a couple of them require a flash for a battery drain issue. Let me know what they find.
__________________
Jack

Dodge Social Care Specialist
Reply With Quote
  #3  
Old 04-24-2012, 04:42 PM
crew man crew man is offline
Amateur
 
Join Date: Feb 2012
Posts: 28
Default

Thanks for the reply, its the 730 Nav radio. The autolamps also quit working at the same time. Don't know if its related or not. I will post results as to what the dealership finds.
Reply With Quote
  #4  
Old 04-24-2012, 05:37 PM
crew man crew man is offline
Amateur
 
Join Date: Feb 2012
Posts: 28
Default

Heard back from the dealership, apperently the diagnosis is a faulty alternator....no big deal until they said it is USA stock and gonna be a week away....I love the Durango, but only 5 weeks old and 1000 miles and the alternator is shot...thank god for warranty....see what kinda loaner / rental they give me.....
Reply With Quote
  #5  
Old 05-08-2012, 03:15 PM
crew man crew man is offline
Amateur
 
Join Date: Feb 2012
Posts: 28
Default

Alternator replaced, bad diode inside according to tech.
Hopefully now, only back for required maintenance....
On a side note, before the battery light came on...auto lamps quit working...tech stated there is a battery saver mode the computers go into when voltage gets low...basically shuts down all creature features to perserve battery power...just FYI
Reply With Quote
  #6  
Old 05-08-2012, 03:49 PM
DodgeCares's Avatar
DodgeCares DodgeCares is offline
Record Breaker
 
Join Date: Jul 2011
Location: Mopar HQ
Posts: 2,076
Default

Quote:
Originally Posted by crew man View Post
Alternator replaced, bad diode inside according to tech.
Hopefully now, only back for required maintenance....
On a side note, before the battery light came on...auto lamps quit working...tech stated there is a battery saver mode the computers go into when voltage gets low...basically shuts down all creature features to perserve battery power...just FYI

Crewman,

Glad they got it fixed. PM me your VIN if you want and I will see if I can get you a couple of free oil changes for your trouble.
__________________
Jack

Dodge Social Care Specialist
Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 dodge ram b1500 v6 3.9l Ronald_Arif Dodge Ram Van 4 10-07-2015 03:16 PM
'96 Indy Without Headlights rampulstilskin 2nd Gen Ram Tech 14 08-19-2015 01:40 PM
1994 5.9L gas has spark and fuel but won't start herche54 2nd Gen Ram Tech 13 07-17-2015 05:38 PM
How to fix p0010 code PyroVicious Dodge Caliber 2 07-16-2015 08:45 PM
Odd Front Left Turn Signal Problem on 99 Ram 2500 kenb1023 2nd Gen Ram Tech 2 07-06-2015 01:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

 

All times are GMT -4. The time now is 07:20 PM.