Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Electronic Throttle Control Problems

Reply
 
 
 
 
Thread Tools Search this Thread
  #41  
Old 12-25-2010, 11:52 AM
willmc43 willmc43 is offline
Registered User
 
Join Date: Dec 2010
Vehicle: 2004 dodge hemi 4x4
Location: missouri
Posts: 7
Default Etc help

Yeah i would like to see or find that too.Just bought our truck 45 days and already problems.Thought i was getting a good deal on truck but have a feeling thats why they got rid of it. 04 1500 hemi 4x4. What i googled said 900. to fix and i'm in constuction so cant do that in winter.Any help would be very helpful.Thanks
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #42  
Old 12-26-2010, 11:17 AM
Buggsy Buggsy is offline
Professional
 
Join Date: Oct 2010
Vehicle: 2003 Ram 1500, 4.7L
Location: Eau Claire, WI
Posts: 204
Default

I don't know of any directions, or how-to articles, but the good news it's actually not the hard.

Take off the Hemi "hat" (plastic air box), and unplug all the sensors connected to it. Next, carefully remove the three bolts that hold the TB on. Carefull remove the TB. It's possible you'll ruin the gasket underneath, so be prepared to need a new one of those. Clean it with brake cleaner.

It's that easy.
Reply With Quote
  #43  
Old 12-27-2010, 11:57 AM
weedahoe's Avatar
weedahoe weedahoe is offline
Site Moderator
Dodge Forum Moderator
 
Join Date: Mar 2009
Vehicle: 04 Dodge Ram QC
Location: South GA
Posts: 18,972
TrickedOut DodgeRam Weedahoe1977
Send a message via AIM to weedahoe Send a message via MSN to weedahoe Send a message via Yahoo to weedahoe
Default

I found this for you but there are also a few threads with pics of guys in tis section who have cleaned their TB

http://dodgeforum.com/forum/3rd-gen-...y-hemivec.html
Reply With Quote
  #44  
Old 12-28-2010, 07:21 PM
willmc43 willmc43 is offline
Registered User
 
Join Date: Dec 2010
Vehicle: 2004 dodge hemi 4x4
Location: missouri
Posts: 7
Default

Thank you both for the help.I am gonna try and take apart and see if this helps.Whomever owned this truck previous to me has taken the black hemi hat off and rigged up with a k&n filter and with a chrome pipe.I'm just hoping this helps the problem.I am so frustrated that i have a new truck and already problems.The ETC light has not came back on but the truck is still dying once in awhile as i am turning or coming to a stop and when i get on the highway and give it gas it hesitates.I'm so disappointed so hopefully cleaning it will do the job.
Reply With Quote
  #45  
Old 01-10-2011, 06:45 AM
willmc43 willmc43 is offline
Registered User
 
Join Date: Dec 2010
Vehicle: 2004 dodge hemi 4x4
Location: missouri
Posts: 7
Default

Took mine apart and cleaned it and replaced the egr valve also. It has been running fine since i did that.I'M hoping that was the problem.Thanks for all the information from everyone.
Reply With Quote
  #46  
Old 01-11-2011, 07:54 AM
ssbracing's Avatar
ssbracing ssbracing is offline
Registered User
 
Join Date: Nov 2010
Location: Sugar Land, Tx
Posts: 18
Default

I replaced mine for about $25.00 from Autozone and it is running great. When you pull the TPS off you have to very careful with the gasket if you are not going to replace the TPS then I would put on a new gasket.
hope this helps
__________________
IF YOU CAN'T RUN WITH THE BIG DOGS
STAY ON THE PORCH!!!!
Reply With Quote
  #47  
Old 02-10-2011, 07:42 PM
cherny780 cherny780 is offline
Registered User
 
Join Date: Nov 2010
Vehicle: 2012 Dodge Ram 1500 5.7L hemi Sport Crew cab w/rambox 4X4
Location: Edmonton, Alberts
Posts: 2
Exclamation Issues with tps light

I have searched threads and topics and I have similar issues and apologize in advance for jacking this thread. I just was not too sure where else to go as i am new to this and have had a lot of success going through threads without having to post ! I have a 2003 Ram 1500 4x4 w/5.7L hemi 190,000 kms. I have these ugrades: Bully Dog, Triple Dog GT Gas gauge/tuner. aired CAI, aired TBS. e3 spark plugs, 8.5mm msd spark plug wires. Just in case it helps.
Here is my issue to begin with my truck runs and starts great, but when I am driving either city or highway at a stop light or going to pass if I want to "gun it" it goes but in about 2 seconds it cuts out and the tps (lightning bolt) light flashes and i have no throttle it still runs and have everything but no throttle. I fix this by shifting into neutral turning the truck off and restart it shift back into drive and it "resets" it and I regain throttle having said this it pulls no codes at all I have even tried this with my obdII plugged in and still no codes or CIL. I have replaced the throttle body hoping this was the issue but to no prevail I have tried to recalibrate the throttle as well as mentioned in other threads. I have updated my bully dog and installed the update and nothing. I have been told that maybe its the drive by wire , the cam sensor or the maf sensor, but before i start changing things and spending more money I wanted to know if any one here could help a brother out. I have talked to the dodge mechanics and they just wanna charge me $140 bucks to run the diagnostics and that is my last resort. if any one could help me it would be greatly appreciated thank you for your time.

Shayne
Reply With Quote
  #48  
Old 02-15-2011, 10:55 AM
chrizyako chrizyako is offline
Registered User
 
Join Date: Feb 2011
Posts: 3
Default ETC light on Dodge 2008

Dodge Ram 1500 4x4 sxt 2008
ETC light flashing codes p2127, p2128, p2138
1.cleaned throttle body
2. replaced fuel peddle
3.dealership ETC relearn,
4.dealership codes read,
5.dealership code reset
ETC light still flashing
6.Dealership check codes, No codes being thrown now
what now
Reply With Quote
  #49  
Old 05-30-2011, 08:18 PM
ladank ladank is offline
Registered User
 
Join Date: May 2011
Posts: 1
Default

2004 Dodge 1500 Hemi
question? I've been having same problems with first Check Engine on for about week, then yesterday ETC and went into limp mode, now about every 15 miles it comes on and goes to limp mode. I cleaned throttle body and replaced it but ETC light still comes on and goes into limp after about 20 miles of driving. I noticed while looking around that muffler is rusted out on intake (front) where pipe connects. Could that cause the problem??

Last edited by ladank; 05-30-2011 at 08:20 PM..
Reply With Quote
  #50  
Old 05-30-2011, 10:30 PM
gator72106 gator72106 is offline
Registered User
 
Join Date: Feb 2008
Posts: 13
Default

http://dodgeforum.com/forum/3rd-gen-...-and-dies.html

read here guys, i just had the same problem yall have.
Mine was a mix of dirty throttle body and dirty EGR, cleaned TB first and it helped alot, i guess the blade would stick a little on the buildup and cause the surging and lightning bolt to come on, after cleaning it still surged a little and would die when slowing for a stop, and also the lightning bolt flashed a couple times more.

I then took the egr off and took it completely apart, took the coil out of the insides and all and cleaned it all up.
put it together and jumped 12v to the two prongs on the bottom of the connector to make sure it was actuating.
apparently a bad/dirty egr can set off the ETC light also.

and make sure you reset the ECM after any TB or EGR cleaning or replacment where the truck can relearn.
If you dont it may act up for a while untill it relearns after a few drive cycles.

everything is solved so far.

Last edited by gator72106; 05-30-2011 at 10:38 PM..
Reply With Quote
  #51  
Old 07-05-2011, 09:01 PM
reddawg9 reddawg9 is offline
Registered User
 
Join Date: Jul 2011
Posts: 2
Question same problems

I am having this problem too with my 07 ram 1500 5.7 hemi. When I had the codes read it came back P0344. With a definition of cam sensor defective (replaced with mopar sensor a month ago), check connector to wiring and sensor, engine mechanical condition-timing belt/chain out of time. Cylinder misfire.

I didn't have any problems for about 2 months then all the sudden it does it 4 times in one week. Usually within the first 20 minutes of driving the ETC light comes on and I lose acceleration. It seems that it only happens when it is really hot out.

Does anyone have any ideas of how I can fix this? The family is going on vacation in 2 weeks, kinds need to fix this fast.
Reply With Quote
  #52  
Old 07-06-2011, 04:44 PM
janie janie is offline
Registered User
 
Join Date: Jan 2010
Vehicle: Dodge Ram 1500 4x4 w/HEMI engine
Location: Laredo, Tx
Posts: 9
Default

Check with JoeHemi, he's got pictures on how to clean your Throttle. They helped me because mine just turned on after 1 year since I cleaned it.
Reply With Quote
  #53  
Old 08-04-2011, 05:07 PM
cabman cabman is offline
Registered User
 
Join Date: Aug 2011
Posts: 1
Default codes

I am a new user and this forum is wonderfull. My 2005 Dodge 2500 Hemi was running wonderfull. The lightning bolt light came on and flashed, it seamed like the transmission was slipping then 30 seconds later it stayed solid and I barely got the truck off the road. It would not stay running. I called a friend and he told me to reset the computer by taking off and touching the pos batter cable to the neg. It didn't work at first but we got gas, mid grade instead of reg. and after a couple minutes tried it again. It ran OK and got us home, about 20miles. I could not get the site to come up that gone fishing listed. But I do have the codes. P0129 and P2172. Any help that you can give me before I have to take it to the dealership would be appreciated. I already have a KnN airfiler and it was just cleaned
Reply With Quote
  #54  
Old 08-31-2011, 02:52 PM
john6410 john6410 is offline
Registered User
 
Join Date: Aug 2011
Posts: 1
Default

Quote:
Originally Posted by abarmby View Post
Do the key trick and find out what codes are being thrown.
What you do is, turn the ignition keyfrom the off to just when the ignition only lights come on, on the dashbaord. but not the last click on the switch so as to start it.
Quickly turn it back to the off position.
Then do this a further 2 times, making three in all and leave it in the ignition on position on the third time.
It should take 2-3 seconds to do this correctly.
Then, on this third try, look at where the oddometer displays the mileage on your dashboard display.
You will find that the computer runs through some checks and any codes that have been thrown, will be displayed in the oddometer as P---- a 4 digit number.
Make a note of these codes and the prefix letter.
Do a search on this board for error codes and look them up.
This will tell you what system/part, is causing your check lights to come on.
That will narrow things down a bit.
Post your codes up on this board and the guys will give you a heads up, on what to either check/clean or replace.
This will work for 03 Hemis and others,as I do it on my 03 and it works 100%.
If you can't get the codes up in the oddometer display, your turning your key incorrectly.
Hope this helps and post up your codes.
Al.
I took mine to a repair shop with the same problem. Error codes 2106,and 2175 . There is a technical service bulletin out.(18-035-02) ECM will have to be programmed only at a dodge dealership. I was told this by a qualified machanic..
Reply With Quote
  #55  
Old 09-29-2011, 12:10 AM
Olerodder's Avatar
Olerodder Olerodder is offline
Registered User
 
Join Date: Apr 2010
Vehicle: I just purchased an 08 Dodge 1500 Ram 2 wheel drive quad cab with Hemi
Location: NorCal
Posts: 22
Default

Haven't been on the site for some time, just been busy moving and trying to get my race car back together.
I had the Electronic Throttle Light come on now three times on my 2008 5.7L. Once it did it twice, but the check engine light did not come on, and it was after leaving a stop light. The truck just "nosed over" for not more than a couple of seconds and then took off again. The next time I was stopping at a stop light and it did the same thing. Those were both in one short trip (the motor was warm) and in a span of maybe 20 minutes. The second time just this week it did it after leaving a stop light and turning a hard left corner..........nosed over and then a second later took off again.
The other thing I have been noticing (I will see if I can check for codes tomorrow morning) it that when I have the computer set to read miles per gallon and come I come to a stop light or have to wait in traffic, it just keeps going down, it got down below 7mpg on the computer. During normal driving on the highway or at a steady speed it will get up to where it normally should be, but if you let it idle it just continues to go down and I have never noticed this before. Wonder if they could be related?
The truck has 43k miles and I do have extended warranty but the Dodge dealer in South San Jose just leaves me cold.
Thanks,
John
Reply With Quote
  #56  
Old 09-29-2011, 09:08 AM
DodgeCares's Avatar
DodgeCares DodgeCares is offline
Record Breaker
 
Join Date: Jul 2011
Location: Mopar HQ
Posts: 1,846
Default

Quote:
Originally Posted by Olerodder View Post
Haven't been on the site for some time, just been busy moving and trying to get my race car back together.
I had the Electronic Throttle Light come on now three times on my 2008 5.7L. Once it did it twice, but the check engine light did not come on, and it was after leaving a stop light. The truck just "nosed over" for not more than a couple of seconds and then took off again. The next time I was stopping at a stop light and it did the same thing. Those were both in one short trip (the motor was warm) and in a span of maybe 20 minutes. The second time just this week it did it after leaving a stop light and turning a hard left corner..........nosed over and then a second later took off again.
The other thing I have been noticing (I will see if I can check for codes tomorrow morning) it that when I have the computer set to read miles per gallon and come I come to a stop light or have to wait in traffic, it just keeps going down, it got down below 7mpg on the computer. During normal driving on the highway or at a steady speed it will get up to where it normally should be, but if you let it idle it just continues to go down and I have never noticed this before. Wonder if they could be related?
The truck has 43k miles and I do have extended warranty but the Dodge dealer in South San Jose just leaves me cold.
Thanks,
John
John,

If you want to PM me your VIN I can check for TSB's on this issue. As far as the MPG's readout, if you are stopped or moving very slowly it should read somewhere near zero since you will get very little MPG's during these conditions.

I would also suggest a different dealer if the one you have been using has bad customer service. No excuse for that. I can send you a list of dealers in your area if you want. If you have a Chrysler Service Contract it is good at any Chrysler dealer.
__________________
Jack

Dodge Social Care Specialist
Reply With Quote
  #57  
Old 12-25-2011, 03:13 AM
Melinda Douglas Melinda Douglas is offline
Registered User
 
Join Date: Dec 2011
Posts: 1
Default

I was just wondering if everyone is still willing to help with the problems previously posted in this thread. Just bought a 2004 ram 1500 5.7 hemi magnum a few weeks ago, took it on a road trip today and having the same exact issues. We are going to get it home and do the key turn code thing and see what we get. I just wanted to ask and make sure posting here for help would be ok...
Reply With Quote
  #58  
Old 12-25-2011, 10:30 PM
Gone Fishin Gone Fishin is offline
Record Breaker
 
Join Date: Feb 2005
Vehicle: 2005 5.7,2500,G-56 6spd, 4x4,SB---2005 3500 Dually, 5.9, 4x4, NV5600 6spd, LB
Location: Bristol, IN
Posts: 2,211
same
Default

Quote:
Originally Posted by Melinda Douglas View Post
I was just wondering if everyone is still willing to help with the problems previously posted in this thread. Just bought a 2004 ram 1500 5.7 hemi magnum a few weeks ago, took it on a road trip today and having the same exact issues. We are going to get it home and do the key turn code thing and see what we get. I just wanted to ask and make sure posting here for help would be ok...

Melinda, Go to Weedahoe's

http://dodgeforum.com/forum/members/...-weedahoe.html

profile and get the FSM it will have all the DTC's listed for your year truck, and is a great troubleshooting guide too.
__________________
2005 Dodge Ram SLT 3500 Dually, 5.9 Cummins, 6sp NV5600, 11.5" LSD 4x4
Reply With Quote
  #59  
Old 12-26-2011, 12:33 AM
PRADO PRADO is offline
Professional
 
Join Date: Dec 2011
Vehicle: 03 ram 1500 qc hemi 4x4
Location: socal
Posts: 128
Default

Just like it was said there is a TSB for that condition and it consist of flashing the pcm on ur truck, certain models actually recomend a new throttle body with the flash.. im picking up my recently purchased ram in a few days and thats the first thing im gonna do is flash the pcm and do a BG throttle service.
Reply With Quote
  #60  
Old 01-12-2012, 11:07 PM
kwinny kwinny is offline
Registered User
 
Join Date: Jan 2012
Posts: 1
Default Throttle body problems

Hi, I'm having problems with my 03 Ram 1500. I followed Abarmby's instructions with the key trick and got the following codes
p0440, p0441, p2106, and p2173 can someone help find out what
these codes mean, it would be greatly appreciated
Reply With Quote
Old 01-12-2012, 11:07 PM
 
 
 
Reply




Tags
08, 2008, 2500, avenger, caliber, control, dashboard, dodge, electronic, light, mileage, panel, problem, problems, ram, thottle, throttle, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 04:48 AM.

Internet Brands, Inc.


Contact Details & Emails