Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

AC Not Cold On Idle / Engine Light Coming On

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-21-2009, 11:31 AM
blile59 blile59 is offline
Registered User
Garage is empty, add now
 
Join Date: Jul 2008
Posts: 8
Question AC Not Cold On Idle / Engine Light Coming On

I have a 02, V8 4.7 1500 with 143,000 miles. Just recently when the truck is idling the AC stops blowing cold air. It's never done that before. The engine light has started to come on about 5 minutes after the truck is started. No problems with cold AC while driving. Any ideas....I'm hoping for a small problem...but I've been told by my backyard mechanic "friends" that it may be the compressor going out. Thanks.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 09-21-2009, 11:39 AM
HouTex HouTex is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2009
Posts: 41
Default

You need to check and make sure the A/C compressor clutch is staying engaged at idle.

Then inspect the sight glass on the reciever dryer (small tank behind grill with a inspection window on top, possibly covered with a blue cap) and check to see if there are any bubbles in the view (A/C on, of course). If so, then your low on refrigerant.

Also make sure the Condensor is clean and not obstructed with debris/dirt etc..
Reply With Quote
  #3  
Old 09-21-2009, 11:46 AM
dazed01 dazed01 is offline
Veteran
Garage is empty, add now
 
Join Date: Aug 2008
Vehicle: 08 trx4, 93 rx7
Location: killeen texas
Posts: 295
Send a message via Yahoo to dazed01
Default

Could be a few things, but if your ac doesn't blow cold at a stop but does when you are driving i would start by checking the condenser fan.
__________________

08 trx4, 35" km2's on moto metal wheels, 2" level.
Reply With Quote
  #4  
Old 09-21-2009, 12:04 PM
blile59 blile59 is offline
Registered User
Garage is empty, add now
 
Join Date: Jul 2008
Posts: 8
Default

Will do. Thanks. I just hope it isn't an arm and leg repair.
Reply With Quote
  #5  
Old 09-21-2009, 04:52 PM
lxman1's Avatar
lxman1 lxman1 is offline
Multi-Section Moderator
Dodge Forum Moderator
2008 Dodge Ram 1500
 
Join Date: May 2008
Vehicle: 2008 QC Ram BigHorn Hemi
Location: Louisville, Ky
Posts: 8,991
Send a message via AIM to lxman1
Default

Yep, sounds like the condenser fan has failed. Under $100 bucks I believe.
__________________
2008 RAM 1500 Sunburst Orange BigHorn. 5.7L HEMI
Reply With Quote
  #6  
Old 09-21-2009, 08:09 PM
cheapbeater cheapbeater is offline
Record Breaker
2000 Honda Elite
My Garage
 
Join Date: Feb 2009
Vehicle: 03 1500 QC Sport 4x4 Hemi
Location: Wisconsin Rapids, WI
Posts: 1,616
Send a message via Yahoo to cheapbeater
Default

+3 on the condenser fan. mine doesnt work, and i have no cold air at idle... they were $80-100 on ebay
just turn on your ac and look at the fan
__________________
BTC Member #012, PICS Secretary of Poon Treasury WISCONSIN AND SURROUNDING GROUP (CLICK HERE)
Reply With Quote
  #7  
Old 09-30-2009, 04:01 PM
blile59 blile59 is offline
Registered User
Garage is empty, add now
 
Join Date: Jul 2008
Posts: 8
Default

Found out that during heavy rains, the condenser fan will short because of moisture getting in. Changed a fuse and now it works. Dodge put out an alert saying the fan had been redesigned to prevent this. Thanks for yalls suggestions!

Click the image to open in full size.
Attached Images
File Type: jpg 2083722136_9bd7ed761b.jpg (78.8 KB, 32 views)
Reply With Quote
  #8  
Old 10-01-2009, 08:50 AM
dazed01 dazed01 is offline
Veteran
Garage is empty, add now
 
Join Date: Aug 2008
Vehicle: 08 trx4, 93 rx7
Location: killeen texas
Posts: 295
Send a message via Yahoo to dazed01
Default

Cool, I'm glad you got it fixed
__________________

08 trx4, 35" km2's on moto metal wheels, 2" level.
Reply With Quote
Old 10-01-2009, 08:50 AM
 
 
 
Reply




Tags
ac, air, air conditioning, blow, blowing, cold, compressor, cooling, dodge, engine, idle, light, ram, stopped

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 06:56 PM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2