Windshield washer jets are not spraying well - DodgeForum.com


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

     
Old 08-05-2015, 07:49 PM
How-Tos on this Topic
 
Last edit by: IB Advertising
See related guides and technical advice from our community experts:

Browse all: Exterior
Print Wikipost

Windshield washer jets are not spraying well

Reply
 
 
  #1  
Old 01-14-2010, 05:51 PM
Trendy Rendy
Trendy Rendy is offline
Rookie
Thread Starter
 
Join Date: Jan 2010
Posts: 99
Default Windshield washer jets are not spraying well

I have a 2005 dodge ram 1500 and when I spray the windshield fluid the drivers side jet just hits the windshield and the passenger jet just pisses out. I thought the hoses were plugged so I shot air into them to clear it up but of didn't solve my problem. Can someone tell me how to fix it?
Reply With Quote
  #2  
Old 01-14-2010, 05:58 PM
OklaHemi's Avatar
OklaHemi
OklaHemi is offline
Champion
 
Join Date: Jun 2009
Location: Collinsville, Oklahoma
Posts: 3,210
Default

when my wifes old envoy did this there was something in the nozzle where it sprays out. i had to completely remove the one that wasnt spraying and clean it out. i think a tooth pick finally got it unclogged. hope it helps
Reply With Quote
  #3  
Old 01-14-2010, 06:09 PM
MikeHTally's Avatar
MikeHTally
MikeHTally is offline
Champion
 
Join Date: Aug 2007
Location: N. Florida
Posts: 4,668
Default

Sewing needle.
Reply With Quote
  #4  
Old 01-14-2010, 08:57 PM
Trendy Rendy
Trendy Rendy is offline
Rookie
Thread Starter
 
Join Date: Jan 2010
Posts: 99
Default

Thanks. I'll try that and hopefully it solve the problem
Reply With Quote
  #5  
Old 01-15-2010, 05:35 PM
Trendy Rendy
Trendy Rendy is offline
Rookie
Thread Starter
 
Join Date: Jan 2010
Posts: 99
Default

Well I tried the needle but it didn't fix it, I even put brake cleaner fluid or something so of can somewhat dissolve it but no luck. Could it just be that my pump is dying or what?
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pdavis53
4th Gen Ram Tech
2
12-04-2015 09:51 AM
Mexii88
2nd Gen Neon
2
11-08-2015 02:10 PM
crazycarroll119
3rd Gen Ram Tech
1
10-08-2015 08:12 PM
dustin6119
Dodge Charger
0
09-26-2015 02:27 AM
jlindseyjr
Dodge Stratus
2
09-16-2015 11:25 AM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 06:28 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send