Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Truck beeps everytime I hit the break pedal

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-19-2010, 04:12 PM
Warior1322 Warior1322 is offline
Registered User
 
Join Date: Jul 2010
Vehicle: 2007 Dodge Ram 1500
Location: Clearwater Beach, FL
Posts: 3
Default Truck beeps everytime I hit the break pedal

Hey guys, I just bought an 07 Ram 1500 and its the first Ram or Dodge I have owned so I was wondering if anyone on here knows or has had it happend to them but recently everytime I push the break pedal down(driving and idle) the truck beeps 1 time. Anyone know why this is and how to fix it, it is really annoying. There is no check engine light and everything else about the truck is working fine. Thanks
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 07-19-2010, 04:26 PM
weedahoe's Avatar
weedahoe weedahoe is offline
Site Moderator
Dodge Forum Moderator
 
Join Date: Mar 2009
Vehicle: 04 Dodge Ram QC
Location: South GA
Posts: 18,822
TrickedOut DodgeRam Weedahoe1977
Send a message via AIM to weedahoe Send a message via MSN to weedahoe Send a message via Yahoo to weedahoe
Default

Never heard of that before. Did you buy it from an individual or a dealer?
Reply With Quote
  #3  
Old 07-19-2010, 04:27 PM
redram2008's Avatar
redram2008 redram2008 is offline
Rookie
 
Join Date: Jun 2008
Vehicle: 2011 ram slt 4x4
Location: bullhead city az
Posts: 78
Default

check all your lights most likely have a break or signal light out ! check if your blinkers flash real fast to . the chime is a light burnt out signal . hope this helps had the same thing on my 2007
Reply With Quote
  #4  
Old 07-19-2010, 04:37 PM
Warior1322 Warior1322 is offline
Registered User
 
Join Date: Jul 2010
Vehicle: 2007 Dodge Ram 1500
Location: Clearwater Beach, FL
Posts: 3
Default

actually the left blinker does blink much faster than the right one..so does this mean my left turn signal is possibly burnt out? I havent noticed it but I will check.
Reply With Quote
  #5  
Old 07-19-2010, 04:47 PM
Mega-Hemi's Avatar
Mega-Hemi Mega-Hemi is offline
Record Breaker
 
Join Date: Jul 2007
Vehicle: 2006 1500 SLT Mega Cab 4x4 5.7/Auto
Location: Back in NY!!
Posts: 1,283
Send a message via Yahoo to Mega-Hemi
Default

Quote:
Originally Posted by Warior1322 View Post
actually the left blinker does blink much faster than the right one..so does this mean my left turn signal is possibly burnt out? I havent noticed it but I will check.
Yes it means one of your left signals (front or rear) is out. If it does it every time you step on the brake, I'd say it's probably the rear. I think the rears share a bulb for turn/stop from '07 and later.
__________________
SS Steps / Fiberglass Tonneau / Power Sun Roof / 20" AE 079 w/ 34" NTGs
Dodge Forum Military Club
Dodge Forum Motorcycle Club
Reply With Quote
  #6  
Old 07-19-2010, 04:51 PM
Warior1322 Warior1322 is offline
Registered User
 
Join Date: Jul 2010
Vehicle: 2007 Dodge Ram 1500
Location: Clearwater Beach, FL
Posts: 3
Default

ahh aight thanks for the info
Reply With Quote
  #7  
Old 07-19-2010, 05:06 PM
04-fourseven's Avatar
04-fourseven 04-fourseven is offline
Record Breaker
 
Join Date: Oct 2008
Vehicle: 2004 QCSB 4x4 1500
Location: Bakersfied, CA
Posts: 1,394
Default

dang it, I was going to say the lamp out signal. lol, good job guys
__________________

Former owner of 2004 QCSB 4.7 4x4... was dearly loved...
New Truck: 2006 F250 PSD Lariat FX4
Reply With Quote
  #8  
Old 07-19-2010, 11:04 PM
rochefort978 rochefort978 is offline
Professional
 
Join Date: Jul 2009
Vehicle: 2003 Dodge RAM 4x4 QC HEMI
Location: Dowagiac, Michigan
Posts: 169
Default

My truck started doing the same thing today but was really uncosistant.. The light would shut off half way to the stop.. but then again the wiring on my truck is messed up.. my turn signals work when they want to.. and sometimes they blink backwards (flip the left on and the right comes on or vice versa)
__________________
Reply With Quote
  #9  
Old 07-19-2010, 11:29 PM
Mega-Hemi's Avatar
Mega-Hemi Mega-Hemi is offline
Record Breaker
 
Join Date: Jul 2007
Vehicle: 2006 1500 SLT Mega Cab 4x4 5.7/Auto
Location: Back in NY!!
Posts: 1,283
Send a message via Yahoo to Mega-Hemi
Default

Quote:
Originally Posted by rochefort978 View Post
My truck started doing the same thing today but was really uncosistant.. The light would shut off half way to the stop.. but then again the wiring on my truck is messed up.. my turn signals work when they want to.. and sometimes they blink backwards (flip the left on and the right comes on or vice versa)
My '02 did that to me once. I stopped at a stop sign and put my right signal on, nothing happened. I shut it off and put it on again, still nothing. Then I said the hell with it and put my left one on, my right signal started flashing so I just went with it. Half way through the turn the right side started flashing. But then it never happened again. Never did figure that one out.
__________________
SS Steps / Fiberglass Tonneau / Power Sun Roof / 20" AE 079 w/ 34" NTGs
Dodge Forum Military Club
Dodge Forum Motorcycle Club
Reply With Quote
  #10  
Old 07-20-2010, 08:23 AM
LinerJoe LinerJoe is offline
Veteran
 
Join Date: May 2008
Vehicle: 2007 Ram 1500 QC 4x4 Hemi / 2006 Star Roadliner / 1966 Ford Mustang Coupe
Location: Indianapolis, IN
Posts: 330
Default

Wow, a question I could actually answer and I'm late to the party. This exact situation happened to me 2 weeks ago. I was really starting to freak about it when I finally put 2 and 2 together, and determined it was a bulb out.

joe
__________________
2007 Dodge Ram 1500 5.7 QC 4x4 Patriot Blue - Cooper Zeon LTZs, Rancho 5ks, 18% tint, 2.5" HBS level
2006 Yamaha Roadliner (113ci V-Twin Beast!) / 2005 Chrysler Town & Country
2002 Yamaha V-Star 650 / 1966 Ford Mustang Coupe
Reply With Quote
Old 07-20-2010, 08:23 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 12:35 AM.

Internet Brands, Inc.


Contact Details & Emails