Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Truck starts but won't stay running

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-01-2011, 10:40 PM
spinner01 spinner01 is offline
Registered User
Garage is empty, add now
 
Join Date: Jan 2011
Vehicle: 2002 Ram 1500 4x4 Quad K&N CAI, Flowmaster 50 CatBack SI/SO, Drilled/Slotted F. Roters, Force Nerfs
Location: The Great North Wet
Posts: 17
Default Truck starts but won't stay running

This problem just started/ out of the blue ... no prior problems ... truck was running fine when I parked it. I have a '02 Ram 1500 5.9. The truck starts but won't stay running at an idle. If I give it gas it stays running, but as soon as I let off on the gas to let it drop to an idle it dies. No engine lights have come on. Any ideas? Thanks in advance.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 01-02-2011, 09:36 AM
MikeHTally's Avatar
MikeHTally MikeHTally is offline
Champion
2006 Chrysler 300
My Garage
 
Join Date: Aug 2007
Vehicle: 2003 1500 QCSB Hemi 4x2
Location: N. Florida
Posts: 4,412
Default

Not sure how easy the 5.9s TB is to clean, but it's a start. Air filter, plugs and wires, too.
__________________
2003 1500 QC Hemi

2006 Chrysler 300C
2008 1/2 Mazda Speed3
Reply With Quote
  #3  
Old 01-02-2011, 04:51 PM
dirtydog's Avatar
dirtydog dirtydog is offline
Moderate User
2008 Dodge Ram 1500
 
Join Date: Oct 2008
Vehicle: 2008 Ram QC 4x4 BigHorn
Location: Albany, NY
Posts: 10,833
Send a message via Yahoo to dirtydog
Default

Sounds like your IAC(idle air control) valve is not working properly. This is mounted to your throttle body.
__________________
Reply With Quote
  #4  
Old 01-02-2011, 10:28 PM
rbrumm's Avatar
rbrumm rbrumm is offline
Veteran
Garage is empty, add now
 
Join Date: Mar 2008
Vehicle: 2011 Outdoorsman Crew Cab
Location: North Central Iowa
Posts: 340
Default

I had that happen when my battery went dead...Would not start with a jump unless I had my foot on the gas. new battery and worked fine. Just a thought.
__________________
2011 Outdoorsman, Truxedo, LineX, Factory step tubes, K&N Filter


Reply With Quote
  #5  
Old 01-03-2011, 10:58 AM
weedahoe's Avatar
weedahoe weedahoe is offline
Site Moderator
Dodge Forum Moderator
Garage is empty, add now
 
Join Date: Mar 2009
Vehicle: 04 Dodge Ram QC
Location: South GA
Posts: 18,780
TrickedOut DodgeRam Weedahoe1977
Send a message via AIM to weedahoe Send a message via MSN to weedahoe Send a message via Yahoo to weedahoe
Default

Check for vacuum leaks also as one big enough would cause idle issues and stalling.
Reply With Quote
  #6  
Old 01-03-2011, 02:23 PM
spinner01 spinner01 is offline
Registered User
Garage is empty, add now
 
Join Date: Jan 2011
Vehicle: 2002 Ram 1500 4x4 Quad K&N CAI, Flowmaster 50 CatBack SI/SO, Drilled/Slotted F. Roters, Force Nerfs
Location: The Great North Wet
Posts: 17
Default

Thanks guys! It indeed was the battery ... thought I'd start there because it was the easiest. It wasn't dead but I had just unhooked it mount some off-road lights. The battery was getting old so I went ahead and replaced it. I started the truck, kept my foot on the brake and RPM's up. Got out of the driveway and got going about 60 mph and then let it coast. The RPM's dropped and it died but I put it in neutral and started it again while coasting. Took it up to about 60 and did it again. This time the RPM's dropped but not to zero. Ended up coasting at an appropiate RPM and after that it has run just fine!

On another note: Just want to say thanks for all the times (almost 2 yrs now) I have come to this forum for advice and repair info without ever registering and asking a question. This time I was at a complete loss and I registered ... so glad I did! Thanks again all.
Reply With Quote
  #7  
Old 01-03-2011, 08:29 PM
rbrumm's Avatar
rbrumm rbrumm is offline
Veteran
Garage is empty, add now
 
Join Date: Mar 2008
Vehicle: 2011 Outdoorsman Crew Cab
Location: North Central Iowa
Posts: 340
Default

Glad you got it figured out.
__________________
2011 Outdoorsman, Truxedo, LineX, Factory step tubes, K&N Filter


Reply With Quote
  #8  
Old 09-08-2011, 11:57 AM
roofseller roofseller is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2011
Posts: 2
Default

Bought a used 2001 Dodge Ram 1500 Larime. Battery was dead when I bought it. Shady Dealer jumped it, ran it all day yesterday, putting on nearly 200 miles its first day on the road, ran beautiful... came out to goto work today, starts but wont stay unless keep my foot on the gas... help!

VIN: 1B7HC13Z01J504957
Year: 2001
Make: Dodge
Style / Body: Quad Cab 4D
Engine: 5.9L V8 MPI
Country of Assembly: United States
Model: Ram 1500 Laramie SLT / ST

Last edited by roofseller; 09-08-2011 at 12:00 PM..
Reply With Quote
  #9  
Old 09-08-2011, 07:52 PM
roofseller roofseller is offline
Registered User
Garage is empty, add now
 
Join Date: Sep 2011
Posts: 2
Default 2001 Ram 1500 SLT

It was definitely the battery... thanks guys.
Reply With Quote
  #10  
Old 01-29-2012, 06:26 PM
boosted-fc3s boosted-fc3s is offline
Professional
Garage is empty, add now
 
Join Date: Oct 2011
Vehicle: 2002 Dodge Ram
Location: Illinois
Posts: 196
Default

Add another one to the list today. My truck wouldnt start at the shop that was doing my lower ball joints. It started fine when they brought it in, but couldnt get it running without holding the gas after. Needed a jump to even turn over. I had them put a new battery in and it started right up and ran fine. They were awfully surprised that I came up with a solution after searching the forums for 5 minutes.
__________________
2002 Dodge Ram 1500 QuadCab Shortbox 4x4 4.7L
2011 Toyota Avalon Limited w/ Nav
Reply With Quote
Old 01-29-2012, 06:26 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 04:34 AM.

Internet Brands, Inc.


Contact Details & Emails