Malfunction Indicator Light - DodgeForum.com



3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Malfunction Indicator Light

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-06-2011, 10:37 AM
boopadoopa's Avatar
boopadoopa boopadoopa is offline
Professional
Thread Starter
 
Join Date: Jul 2008
Vehicle: 2007 Ram Quad Cab 5.7 4X4
Location: Freedom Pa.
Posts: 236
Default Malfunction Indicator Light ***Solved****

Coming home from camping Monday My light came on and stays on. I did the Key on/off/on/off/on/off/on and the odometer goes to ------------- then says "done"
But no code is flashed? But the light is staying on? Think pulling the battery terminal for 30 minutes or so will reset it and turn it off? Maybe Ill go to Auto zone and get it checked on way home but if no code is showing when I test it do you think they will get a code?

Also do I pull the positive terminal or negative or doesn't it matter? any one will break the circuit so it shouldn't matter?

Last edited by boopadoopa; 07-07-2011 at 10:36 AM. Reason: found problem
Reply With Quote
  #2  
Old 07-06-2011, 11:17 AM
HammerZ71's Avatar
HammerZ71 HammerZ71 is offline
Administrator
Dodge Forum Administrator
 
Join Date: Jul 2007
Vehicle: 2014 2500 CTD 4x4
Location: South Georgia/East Florida
Posts: 24,656
Default

Take it to the auto parts store and have them pull the code. In all likelihood it's just an EGR (normal wear item and about the right time to go out on an '07), or some other minor sensor...
Reply With Quote
  #3  
Old 07-06-2011, 12:00 PM
boopadoopa's Avatar
boopadoopa boopadoopa is offline
Professional
Thread Starter
 
Join Date: Jul 2008
Vehicle: 2007 Ram Quad Cab 5.7 4X4
Location: Freedom Pa.
Posts: 236
Default

Thats what i figured I got 59000 miles on it I just thought a code would show when i turned the key in sequence.. No biggie.. ill take it today
Reply With Quote
  #4  
Old 07-07-2011, 10:34 AM
boopadoopa's Avatar
boopadoopa boopadoopa is offline
Professional
Thread Starter
 
Join Date: Jul 2008
Vehicle: 2007 Ram Quad Cab 5.7 4X4
Location: Freedom Pa.
Posts: 236
Default

So my code turned out to be a P0524 Low Oil Pressure I found this in the search of the forum

http://dodgeforum.com/forum/3rd-gen-...1500-hemi.html

Good stuff and it helped me out... Thanks
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 dodge ram b1500 v6 3.9l Ronald_Arif Dodge Ram Van 4 10-07-2015 03:16 PM
Are Codes 17 and 41 something or nothing? SteveR Dodge Ram Van 5 07-23-2015 09:05 PM
turn signals stopped working but 4 ways worked BrandonBuc'em 2nd Gen Ram Tech 4 07-15-2015 02:02 PM
Odd Front Left Turn Signal Problem on 99 Ram 2500 kenb1023 2nd Gen Ram Tech 2 07-06-2015 01:44 PM
Buzzing noise when right directional is on barrd70 2nd Gen Dakota 0 07-05-2015 02:23 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 03:40 AM.