The complete story on the Trailer Brake Controller on 2010 Models. - Page 8 - DodgeForum.com


4th Gen Ram Tech 2009+ and up Rams: This section is for TECHNICAL discussions only, that involve the 2009 and up Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

     
Old 08-14-2015, 07:12 PM
How-Tos on this Topic
 
Last edit by: IB Advertising
See related guides and technical advice from our community experts:

Browse all: Towing & Hauling Guides
Print Wikipost

The complete story on the Trailer Brake Controller on 2010 Models.

Reply
 
 
  #71  
Old 10-12-2010, 11:13 PM
ken99
ken99 is offline
Rookie
 
Join Date: Jul 2010
Location: Montana
Posts: 55
Default

Quote:
Originally Posted by crazy5806 View Post
talked to dodge and customer service and all they seem to be able to tell me is that the controller will only work as a replacement and won't work as add on.
It's been amazing how ignorant Dodge Customer Service has been over this issue with the integrated trailer brake module (aka, controller). Yes, the controller will work as an add on. Go to:

http://www.ramforumz.com/showthread.php?t=52410

for the best discussion regarding the aftermarket install of the factory ITBM.

Quote:
Originally Posted by crazy5806 View Post
I bought controller from dealer and installed it my self and had it added to build sheet and had system flashed it shows up in evic like it is supposed to but trailer brakes don't work. I am at a loss here has anybody elese had this problem?
The system flashed properly with the ITBM installed, so it appears ITBM is good. If the controller is not displaying one of the error codes (SC, Sb, CF) and is not activating the gain display when you connect the trailer, I would suspect a bad ground lead on the trailer side. Time to dig out the multimeter and start tracing wires.
Reply With Quote
  #72  
Old 10-13-2010, 11:54 AM
crazy5806
crazy5806 is offline
Registered User
 
Join Date: Oct 2010
Posts: 5
Default

The trailer worked fine last time i used it with wy other truck and i am in the process of trying to check another trailer
Reply With Quote
  #73  
Old 10-13-2010, 01:03 PM
it's all dodge
it's all dodge is offline
Rookie
 
Join Date: Jan 2009
Location: harrison, ar
Posts: 87
Default

You have the early build date, most likely, CRAZY5806. Look on your door jam, it'll tell you build date. Sounds just like mine, they hooked it up, took my $223 and I had nothing. You prob got the old wiring harness.
Reply With Quote
  #74  
Old 10-13-2010, 02:54 PM
ken99
ken99 is offline
Rookie
 
Join Date: Jul 2010
Location: Montana
Posts: 55
Default

Quote:
Originally Posted by crazy5806 View Post
The trailer worked fine last time i used it with wy other truck and i am in the process of trying to check another trailer
Probably wouldn't hurt to check the fuses in the TIPM under the hood. No less than 7 fuses are related to the trailer tow, controller and trailer brake systems. Look for J02, J09, M23, M24, M45, M46 and M52. Labels are listed in the owners manual. Some are trailer light feeds, but the ITBM may not work if any are blown.
Reply With Quote
  #75  
Old 10-13-2010, 06:15 PM
crazy5806
crazy5806 is offline
Registered User
 
Join Date: Oct 2010
Posts: 5
Default

mine was built in early 2010 feb. to be exact. so what did you end up doing about it? did you put aftermarket controller in the truck? if you put aftermarket controller in was it intagrated like factory or just mounted under dash? Thanks any info you can give me will be apperciated.
Reply With Quote
  #76  
Old 10-13-2010, 06:19 PM
crazy5806
crazy5806 is offline
Registered User
 
Join Date: Oct 2010
Posts: 5
Default

when i hook to trailer it shows connected and all the lights work just no trailer brakes display on controller shows brakes being applied but no trailer brakes
Reply With Quote
  #77  
Old 10-15-2010, 12:46 PM
crazy5806
crazy5806 is offline
Registered User
 
Join Date: Oct 2010
Posts: 5
Default

I have done some more checking and talked to mopar tech support. They have had some serious problems with the controllerssuch as the trailer brakes locking up while going down the road. They strongly advise againest putting the controller in.
Reply With Quote
  #78  
Old 10-15-2010, 02:26 PM
72combo's Avatar
72combo
72combo is offline
Champion
 
Join Date: Dec 2007
Location: Ontario, Canada
Posts: 3,563
Default

No wonder they don't want to sell it.
Reply With Quote
  #79  
Old 10-18-2010, 09:26 AM
autoengmike
autoengmike is offline
Registered User
 
Join Date: Jun 2010
Posts: 18
Default

Went to my dealer and the first reply they have is the trailer brake controller cannot be added. I gave them the part number 56029431AF and they printed out this response to that number. It seems they are planning to release a kit to install on those that do not have it from the factory. My truck is Laramie 2010.

65561000
S99170B
Global Parts Order Processing
Service Repair Tips
HUMES CHRYSLER JEEP DODGE
September 3, 2010
08:26
Part Number: 56029431AF
Part Description: Integrated Trailer Brake Module
PLEASE PROVIDE A COPY OF THIS SHEET TO THE SERVICING TECHNICIAN
PRIOR TO ORDERING THIS PART, THE FOLLOWING MUST BE VERIFIED:
This part can only be used as a replacement on vehicles originally manufactured with the Integrated Trailer Brake system. Do
not attempt to use this module for the purpose of adding Integrated Trailer Brake to a vehicle that was not originally
equipped. You will encounter configuration difficulties. MOPAR is developing a kit. Expected availability is early Fall,
2010.
Contact Us at CAGRIS@Chrysler.com for feedback related ONLY to this GPOP Tech Tip. DO NOT email regarding repair
procedures unrelated to this Tech Tip or part order inquires. Please include the Part Number (s) and Tech Tip Part
Description of the Tech Tip you are referencing for our tracking system.
CHRYSLER RESERVES THE RIGHT TO BACK CHARGE DEALERS THAT DO NOT COMPLY WITH CHRYSLER
WARRANTY AND POLICY PROCEDURES AS OUTLINED IN THE DEALER POLICIES AND PROCEDURES MANUAL


Does anyone know if this kit is out yet?

Thanks, Mike
Reply With Quote
  #80  
Old 10-18-2010, 10:29 AM
sully0263
sully0263 is offline
Registered User
 
Join Date: Oct 2010
Location: Halifax Nova Scotia
Posts: 10
Default

I just went through this last week and my dealer printed off the same thing for me. Don’t think the fix is out yet but it would be nice to know when it will be. It was the first my dealer heard about it and was surprised because he said he installed about a dozen over the summer and all worked fine. I guess you could still order it and say its to replace an existing one maybe and install it you self ... you will still have to get the dealer to flash it up for ya though
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Davids Charger
Dodge Charger
2
07-22-2015 12:55 AM
Stratus0159
Dodge Stratus
6
07-18-2015 07:51 PM
JoshSlash87
3rd Gen Ram Tech
1
07-14-2015 07:51 AM
DakotaDon
Dodge Journey
0
07-11-2015 06:25 PM
59skippy
Dodge Journey
5
07-06-2015 02:04 PM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 05:41 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send