Door Lock Problem - DodgeForum.com



4th Gen Ram Tech 2009+ and up Rams: This section is for TECHNICAL discussions only, that involve the 2009 and up Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Door Lock Problem

Reply
 
 
  #1  
Old 04-02-2011, 03:27 AM
Der Dummkopf's Avatar
Der Dummkopf
Der Dummkopf is offline
Professional
Thread Starter
 
Join Date: Jun 2010
Location: California
Posts: 106
Default Door Lock Problem

I have a 2009 Dodge Ram 1500 ST Quad Cab. And Since I got the truck I've had a problem with locking my doors. I Don't have keyless entry. So, everytime I get out of my truck I rely on the "lock" button on my door. Thing is, sometimes (not always), I hit the lock button and it doesn't respond. It takes about a minute to respond. What could be the problem? Should I take it to the dealership to inspect it?
Reply With Quote
  #2  
Old 04-02-2011, 12:57 PM
roberttheall
roberttheall is offline
Professional
 
Join Date: Feb 2006
Location: America
Posts: 242
Default

Quote:
Originally Posted by Der Dummkopf View Post
I have a 2009 Dodge Ram 1500 ST Quad Cab. And Since I got the truck I've had a problem with locking my doors. I Don't have keyless entry. So, everytime I get out of my truck I rely on the "lock" button on my door. Thing is, sometimes (not always), I hit the lock button and it doesn't respond. It takes about a minute to respond. What could be the problem? Should I take it to the dealership to inspect it?
Is it still under warranty? If not I would take the door panel off, and make sure the connection on the unluck/lock button is secure, maybe it is loose, unplug it and plug it back in and see what that does.
Reply With Quote
  #3  
Old 04-02-2011, 02:00 PM
Der Dummkopf's Avatar
Der Dummkopf
Der Dummkopf is offline
Professional
Thread Starter
 
Join Date: Jun 2010
Location: California
Posts: 106
Default

I believe its still under warranty, Its a 2009 and only has 17,000 miles on it.
Reply With Quote
  #4  
Old 04-05-2011, 03:06 PM
08DodgeTRX's Avatar
08DodgeTRX
08DodgeTRX is offline
Professional
 
Join Date: Dec 2008
Location: Sherwood, AR
Posts: 112
Default

Yeah take it in to check it out.....

btw, how do you like the bedarmor?
Reply With Quote
  #5  
Old 04-06-2011, 01:32 AM
Der Dummkopf's Avatar
Der Dummkopf
Der Dummkopf is offline
Professional
Thread Starter
 
Join Date: Jun 2010
Location: California
Posts: 106
Default

The Bed Armor is actually quite nice. It took a little while to prep the whole bed, but it was well worth the work.
Reply With Quote
  #6  
Old 04-06-2011, 07:07 PM
lineguy
lineguy is offline
Amateur
 
Join Date: Mar 2009
Location: Iowa
Posts: 35
Default

Let us know what you figure out. Some may not agree but this seems like the same issue those of us with remote locks are having with our remotes not working. There is a very long post about this. I have had it where my remote wouldn't work and I had my window down so I reached in and the lock button wouldn't work, let it sit for a short while and it started working. Let us know what they find.
Reply With Quote
  #7  
Old 04-08-2011, 11:06 AM
Tuck479
Tuck479 is offline
Amateur
 
Join Date: Dec 2010
Posts: 32
Default

I notice that my door lock did that to me once as well (09 ram 1500 quad cab 4x4) but it hasn't since....
Reply With Quote
  #8  
Old 04-08-2011, 03:05 PM
djr04
djr04 is offline
All Star
 
Join Date: Jul 2006
Location: South Dakota
Posts: 807
Default

I had the same problem on my 09 1500. It had the factory remote start/keyless entry and sometimes both the remote and the door switch would fail to lock/unlock the doors. Since I have replaced the factory remote start with an aftermarket with 2 way capability, I haven't noticed the problem once, and I tend to still use the factory key to lock/unlock the truck.
Reply With Quote
  #9  
Old 04-08-2011, 04:14 PM
Dr. Bill
Dr. Bill is offline
Veteran
 
Join Date: Jan 2009
Posts: 399
Default

I have a 2009 CC and my lock button fails to work pretty often. It acts more like an electronic/computer confusion rather than a switchware problem. I have the remote start keyless entry and many times if I unlock the door with the fob and grab something and quickly try to lock with the switch, it will not work for several attempts. It acts like it has to clear some junk out of memory. It is very irritating, but many things about the 4th Gen irritate me.
Reply With Quote
  #10  
Old 04-09-2011, 12:31 AM
Kbabiasz06
Kbabiasz06 is offline
Registered User
 
Join Date: Mar 2010
Location: Macomb
Posts: 38
Default

Quote:
Originally Posted by Der Dummkopf View Post
I believe its still under warranty, Its a 2009 and only has 17,000 miles on it.
Warranty for that is covered under 3yr/36000 mile. Unless you have a service contract then its covered under the length of that contract
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
janicedauw
Dodge Caravan
1
08-08-2015 03:12 AM
ddareddevil
Dodge Charger
1
07-13-2015 12:52 PM
0_7_hemi
3rd Gen Ram Tech
7
07-09-2015 02:38 PM
tbugden
1st Gen Dakota
6
07-05-2015 11:39 PM
Mopar 03
2nd Gen Ram Tech
10
07-04-2015 07:19 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 05:24 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send