Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 4th Gen Ram Tech
Sign in using an external account
Register Forgot Password?


4th Gen Ram Tech 2009+ and up Rams: This section is for TECHNICAL discussions only, that involve the 2009 and up Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Hemi engine whine/squeal

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-28-2011, 03:27 PM
2010 TRX4 2010 TRX4 is offline
Professional
Garage is empty, add now
 
Join Date: Oct 2011
Vehicle: 2013 Express regular cab
Location: WMASS
Posts: 134
Default Hemi engine whine/squeal

Good informitave forum. Since day one I have had a high piched squeal when at idle,no chirp from valves, you really cannot hear it while driving. You can really hear it next to a building. The engine runs like a champ. I went to my dealer for my 6000 mile service and had him take a peek at it. The tech said that he hears this loud squeal from just about all recent built hemi's. He said it is due to the exhaust set up that creates the whine. This is a pretty reputable service dept. It almost sounds like a bad belt or a power steering whine. I searched the forum and did find some that had the same issue. Can anybody tell me your experience if you have one, I am curious. Thanks all!!!!
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 10-28-2011, 07:08 PM
09YellowHemiRam's Avatar
09YellowHemiRam 09YellowHemiRam is offline
Registered User
Garage is empty, add now
 
Join Date: Apr 2009
Vehicle: 2009 detonator yellow ram 1500 sport
Location: Geneva oh.
Posts: 9
Default

I had the same issue the stealership changed every front acc. before they figured it was the water pump like I told them it was.
Reply With Quote
  #3  
Old 10-28-2011, 09:19 PM
Mikeyyy816's Avatar
Mikeyyy816 Mikeyyy816 is offline
Record Breaker
Garage is empty, add now
 
Join Date: Mar 2011
Vehicle: 2009 Dodge Ram 1500 5.7L
Location: South, FL
Posts: 1,027
Default

Quote:
Originally Posted by 09YellowHemiRam View Post
I had the same issue the stealership changed every front acc. before they figured it was the water pump like I told them it was.
That sucks prob. a crap load of visits to the dealer....

Hell if it's under warranty let them waste there time and $$, sucks to hear that they can't take anyone's input...
__________________
09 RAM, HEMI, FUKKED Headlights, RetroSolutions 6K HID Heads & Fogs, HID Rev Lights, Magna CatBack Exhaust, BT Catch Can, SC Programmer 93 TUNE, 5% Window Tint, Infinity Reference, Kenwood DDx-419, LED Interior Lights, Bilstein 5100 2.8", 1" TGC RS, AirLift 1000's
Reply With Quote
Old 10-28-2011, 09:19 PM
Reply
 
 
 




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 04:32 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2