Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 4th Gen Ram Tech
Sign in using an external account
Register Forgot Password?


4th Gen Ram Tech 2009+ and up Rams: This section is for TECHNICAL discussions only, that involve the 2009 and up Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Engine Light on !!!??

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-18-2012, 09:31 PM
Peter sask Peter sask is offline
Amateur
2009 Dodge Ram 1500
 
Join Date: Jun 2011
Vehicle: 09'Ram 1500 Hemi
Posts: 49
Default Engine Light on !!!??

Went to town,parked it,let it sit for 2hours and when I got back in the engine light was on. It doesnt have any massages in display.

Nice warm day,truck is stock 09 Ram 1500 Hemi
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 03-18-2012, 09:38 PM
CarGuyOhio's Avatar
CarGuyOhio CarGuyOhio is offline
Admin formally known as 94rt10ohio
2004 Dodge Ram SRT-10
My Garage
 
Join Date: Apr 2005
Vehicle: 12 Challenger SRT Yellow Jacket, 14 Wranger Sahara 2 Door
Location: Curtice, OH
Posts: 9,022
Default

Well, there will be no hope here given that info. If you have warranty just take it in, if not go to a autozone type place, they will scan for free. Then we may have some guideance based on the code.
__________________
14 Jeep Wrangler Sahara 2 Door
12 Challenger SRT 392 Yellow Jacket Kenne Bell Supercharged among others.
Reply With Quote
  #3  
Old 03-19-2012, 08:38 PM
Huntjunkie41's Avatar
Huntjunkie41 Huntjunkie41 is offline
Professional
Garage is empty, add now
 
Join Date: May 2010
Vehicle: 2010 Ram 1500 CC 4x2
Location: Va Beach
Posts: 153
Default

Could be just the Gas cap with no code like that! take the cap off and reinstall.
__________________
2010 Ram 1500 (Big Horn) Crew Cab 4X2. Hemi of course!
Reply With Quote
  #4  
Old 07-18-2012, 07:51 AM
Lonecoyote69 Lonecoyote69 is offline
Registered User
2012 Dodge Ram 1500
My Garage
 
Join Date: Feb 2011
Posts: 10
Default

I just removed my fuel tank filter, full I mean full of dust, washed it out and rerouted a new vent line to under hood, this is an issue with Dodge trucks and lots of GM vehicles that travel on dusty roads. My light just came on yesterday, I had been going to reroute the vent line but hadn't, now my light is on, I am just disconnecting the battery for a reset, hope it works. LCD.
Reply With Quote
  #5  
Old 07-18-2012, 01:12 PM
POWER SEDAN's Avatar
POWER SEDAN POWER SEDAN is offline
Captain
Garage is empty, add now
 
Join Date: Sep 2010
Posts: 633
Default

Acutally the '09 does have a indicator acknowledging when the fuel cap is loose on the dash.
Reply With Quote
  #6  
Old 07-18-2012, 04:50 PM
pavement_hater pavement_hater is offline
Veteran
Garage is empty, add now
 
Join Date: Aug 2007
Vehicle: 2013 Ram 2500 Megacab Cummins G56 trans/ 2013 Dart Aero 1.4T
Location: North East, MD
Posts: 280
thelastpartriot
Default

Doesn't 09 have the option to cycle the key to get the codes? If so its quicker than a trip to the parts store to find out whats wrong.
__________________

2013 Ram 2500 Megacab 6.7L Cummins G56
2013 Dart Aero 1.4L 6 speed
Reply With Quote
  #7  
Old 07-18-2012, 10:57 PM
Lonecoyote69 Lonecoyote69 is offline
Registered User
2012 Dodge Ram 1500
My Garage
 
Join Date: Feb 2011
Posts: 10
Default

Yes removing the battery cable removes the engine light. Used the truck all day no return of the light, so its the fuel tank filter that caused this issue.
Reply With Quote
  #8  
Old 07-19-2012, 06:53 AM
BULLRAM's Avatar
BULLRAM BULLRAM is offline
Veteran
2009 Dodge Ram 1500
 
Join Date: Aug 2007
Location: HOUSTON,TEXAS
Posts: 495
Default

Hope that cures the problem...if it comes back on, check the codes, if it starts spitting out all o2 sensor codes, it is the PCM, a lot of the 09's like mine did that , but i would have to let it sit and idle for a while till it came on, some of the 09's had a bad PCM and it is replaced under warranty, no problems since 09 now......let us know
__________________
99 -EC-(GONE) 18 WHEELER PARKED ON THE FREEWAY AT NIGHT NO LIGHTS AROUND I DROVE INTO THE BACK OF IT
09- 2WD- CCSB -5.7 AUTO-TRAILER PACKAGE-Y.E.S. SEATS-REN-DUALS-LONE STAR PACKAGE-K/N DROP IN- SIDE DECAL REMOVED - UPDATED HEMI EMBLEMS-20'S- SUPERCHIPS 3865--7 INCH CST LIFT
Reply With Quote
  #9  
Old 07-20-2012, 10:04 PM
bmbhntr bmbhntr is offline
Registered User
Garage is empty, add now
 
Join Date: Jun 2009
Vehicle: 2009 Dodge Ram Laramie
Location: Carlock, Illinois
Posts: 15
Default

Just went thru this. Check eng lite came on, had it checked and was told it probably was a speck of carbon came loose in cyl. They reset lite and I added additive to gas tank. Lite came on again a couple of days later so back I went. Turns out I had an ignition coil going bad. Mine is a '09 with almost 70,000 mi.
Reply With Quote
  #10  
Old 07-22-2012, 12:26 AM
stvsherrod's Avatar
stvsherrod stvsherrod is offline
Professional
1968 Chevrolet Chevelle
 
Join Date: Sep 2009
Vehicle: 09 Ram Sport
Location: Ok..
Posts: 234
Default

Quote:
Originally Posted by BULLRAM View Post
Hope that cures the problem...if it comes back on, check the codes, if it starts spitting out all o2 sensor codes, it is the PCM, a lot of the 09's like mine did that , but i would have to let it sit and idle for a while till it came on, some of the 09's had a bad PCM and it is replaced under warranty, no problems since 09 now......let us know
So what have you heard about the PCM? I've had mine replaced once because it starting having issues starting. Less than 1000 since and it's doing the same thing again. Driving through the apartment parking lot last night I hit a bump in the road and the truck shut completey off again.
__________________
...............This I will defend...............
Reply With Quote
Old 07-22-2012, 12:26 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 11:55 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2