Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 4th Gen Ram Tech
Sign in using an external account
Register Forgot Password?


4th Gen Ram Tech 2009+ and up Rams: This section is for TECHNICAL discussions only, that involve the 2009 and up Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Check Engine Light...Catalytic Converter on a 2009 Hemi??

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-24-2013, 02:34 PM
BullyT BullyT is offline
Professional
2009 Dodge Ram 1500
 
Join Date: Sep 2011
Posts: 153
Default Check Engine Light...Catalytic Converter on a 2009 Hemi??

My Check Engine light came on a few weeks ago and I've been back and forth to the dealer I several times. They've replaced a few components based on code(s) but within a couple of days the Check Engine light comes back on. Just dropped it back off at the dealer and now they say the catalytic converter is causing an efficiency code. Truck is a 2009 Hemi with 146,000 km (90,000 miles).

They say I need a new catalytic converter. Not cheap! Canadian emissions warranty is 8 years...or 130,000km (80,000 miles). 8 years is great if you drive 10,000 miles a year. Dealer has actually been good, and I appreciate that troubleshooting CEL (MIL) lights can be a pain in the ***...but I've never had a catalytic converter go on any vehicle I've ever owned going back over 30 years. Dealer has a call in to Chrysler Canada about goodwill warranty as I'm just over the mileage limit.

Anybody else on here had an issue with a catalytic converter? Thoughts?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 09-24-2013, 02:53 PM
oldjeep's Avatar
oldjeep oldjeep is offline
Champion
Garage is empty, add now
 
Join Date: May 2009
Vehicle: 2009 2wd SLT Crew Cab
Location: MN
Posts: 3,189
Default

Do you happen to have a tuner on that truck?
__________________
09 Ram 1500 2WD SLT Hemi Crew Cab
http://www.oldjeep.com
Reply With Quote
  #3  
Old 09-24-2013, 05:40 PM
BullyT BullyT is offline
Professional
2009 Dodge Ram 1500
 
Join Date: Sep 2011
Posts: 153
Default

Quote:
Originally Posted by oldjeep View Post
Do you happen to have a tuner on that truck?
No tuner. Everything is completely stock. Truck still looks *******ly new and service manager today commented that the truck has "obviously been looked after". Runs very well--only sign there is an issue is the Check Engine light. It's only seen mid-range gas, except when I tow my boat...I fill with premium then.
Reply With Quote
  #4  
Old 09-24-2013, 06:40 PM
oldjeep's Avatar
oldjeep oldjeep is offline
Champion
Garage is empty, add now
 
Join Date: May 2009
Vehicle: 2009 2wd SLT Crew Cab
Location: MN
Posts: 3,189
Default

I assume that they already replaced the downstream O2
__________________
09 Ram 1500 2WD SLT Hemi Crew Cab
http://www.oldjeep.com
Reply With Quote
  #5  
Old 09-24-2013, 10:50 PM
BullyT BullyT is offline
Professional
2009 Dodge Ram 1500
 
Join Date: Sep 2011
Posts: 153
Default

Quote:
Originally Posted by oldjeep View Post
I assume that they already replaced the downstream O2
I'm not sure if they've replaced the downstream O2 sensor. The service manager mentioned the possibility of an issue with a new pre-cat O2 sensor and the existing downstream O2 sensor. Because I've made a number of trips to the dealer for the same problem they are working off the original work order--I don't have copies of the paperwork at this point. Common sense would dictate you'd check/replace the downstream O2 sensor before saying the catalytic convertor has failed. I don't know how specific the codes are. Appreciate your comment--it's a good point.
Reply With Quote
  #6  
Old 09-27-2013, 10:38 AM
DodgeCACares's Avatar
DodgeCACares DodgeCACares is offline
All Star
Garage is empty, add now
 
Join Date: Jul 2012
Posts: 782
Default

BullyT,

I'm sorry to hear about your issues with you Ram. I spoke with you previously about a concern, and was wondering if your were servicing with the same dealer.

If your issue is still outstanding and you would like addition assistance, please feel free to PM me and I'd be happy so review with your dealer.
__________________
Dave P.
Top Care Specialist
Chrysler Canada
Reply With Quote
  #7  
Old 09-27-2013, 05:11 PM
BullyT BullyT is offline
Professional
2009 Dodge Ram 1500
 
Join Date: Sep 2011
Posts: 153
Default

Quote:
Originally Posted by DodgeCACares View Post
BullyT,

I'm sorry to hear about your issues with you Ram. I spoke with you previously about a concern, and was wondering if your were servicing with the same dealer.

If your issue is still outstanding and you would like addition assistance, please feel free to PM me and I'd be happy so review with your dealer.
Thank you, Katie. Yes, we did speak previously about another issue and you were very helpful in getting it resolved. I wanted to acknowledge that publicly on this forum, so people will realize that "Dodge Cares" does monitor this board and will work with Ram owners to get any concerns resolved.

I will send you a PM regarding the status of my current issue. Thank you again!
Reply With Quote
  #8  
Old 09-28-2013, 11:37 AM
maka maka is offline
Amateur
2012 Dodge Ram 1500
 
Join Date: Jan 2007
Posts: 38
Default

I believe it, my uncle has 115k miles on his 2010 and his cat is going bad, its been misfiring for 2 months and running like crap and the exhaust smells. Ive replaced plugs, coils and fuel injectors...
__________________
2012 RAM 1500 DEEP CHERRY RED 2/4 LOWERED
2WD, HEMI SINGLE CAB SHORT BED
MAGNAFLOW 12288, RBZ MYGIG, 22 INCH CHROME WHEELS
Reply With Quote
  #9  
Old 09-28-2013, 10:55 PM
BullyT BullyT is offline
Professional
2009 Dodge Ram 1500
 
Join Date: Sep 2011
Posts: 153
Default

Quote:
Originally Posted by maka View Post
I believe it, my uncle has 115k miles on his 2010 and his cat is going bad, its been misfiring for 2 months and running like crap and the exhaust smells. Ive replaced plugs, coils and fuel injectors...
The situation with my truck is quite different. The truck is running great--if it weren't for the illuminated Check Engine light you'd never know anything is wrong. Well, the MDS system also doesn't work with the CEL on but the truck actually runs a bit better without the MDS kicking on and off.

With respect to your uncle's truck, it would seem to me that the misfiring and "running like crap" could be what damaged the catalytic converter.
Reply With Quote
  #10  
Old 09-30-2013, 11:34 AM
BULLRAM's Avatar
BULLRAM BULLRAM is offline
Veteran
2009 Dodge Ram 1500
 
Join Date: Aug 2007
Location: HOUSTON,TEXAS
Posts: 495
Default

May not be related but, mine came on when i first got it, and the o2 sensor codes starting popping up, truck running perfect, just the light, turned out to be the PCM in our trucks for 09 had some problems,resulting in the o2 codes, new PCM and a reflash, and it has not come back on in 4 years.....
__________________
99 -EC-(GONE) 18 WHEELER PARKED ON THE FREEWAY AT NIGHT NO LIGHTS AROUND I DROVE INTO THE BACK OF IT
09- 2WD- CCSB -5.7 AUTO-TRAILER PACKAGE-Y.E.S. SEATS-REN-DUALS-LONE STAR PACKAGE-K/N DROP IN- SIDE DECAL REMOVED - UPDATED HEMI EMBLEMS-20'S- SUPERCHIPS 3865--7 INCH CST LIFT
Reply With Quote
Old 09-30-2013, 11:34 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 06:41 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2