Go Back   DodgeForum.com > Dodge Cars > Dodge Avenger
Sign in using an external account
Register Forgot Password?


Dodge Avenger This forum hosts discussion areas for both the 95-00 and 08-14 Dodge Avenger Coupes and Sedan

Automatic Transmission shifting hard

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-24-2012, 02:40 PM
Partsman41953 Partsman41953 is offline
Registered User
 
Join Date: Oct 2010
Posts: 19
Default Automatic Transmission shifting hard

Hi all,

I have a 1997 Avenger ES 2.5 with 131,000 miles on it. I have a problem that when you slow down and accelerate back up the transmission bangs into gear. To keep this from happening I try to accelerate very easy until the car builds up speed again. I took it to my local mechanic and he was not quite sure what the problem is. I thought it could be a mount but they are in good shape. It also seems like the car has lost some power but that might be because I try not to accelerate hard at this time.

Could it possibly be a speed senor or something like that?

Glenn
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
Old 02-24-2012, 02:40 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 02:36 PM.

Internet Brands, Inc.


Contact Details & Emails