Go Back   DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Sign in using an external account
Register Forgot Password?


Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

map sensor problems?

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-06-2009, 12:42 PM
bullet1118 bullet1118 is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 11
Default map sensor problems?

Hey all, I'm having map sensor code 0108. van idles very bad tach just jumps up and down and so does the engine. I can't go faster than 45mph. Van lurches forward when stopped at a light and act like it wants to stall. I replace the map sensor twice and replace the tps sensor and still same problem. Funny thing is I can drive the van in auto stick and drive a fast as I want. Also getting black smoke out the exaust. When I put the new map sensor on I reset everything disconneted the battery and everything was fine for a day or two then map code came back. All this happen initially after a gas fill up. 02 caravan 3.8l Getting ready to take it to the dealer before I found this site. Thanks for any help
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 08-06-2009, 06:05 PM
kev2 kev2 is offline
Veteran
Garage is empty, add now
 
Join Date: Apr 2009
Posts: 339
Default

P0108 (M)
Manifold Absolute Pressure/Barometric Pressure Circuit High Input
MAP sensor input above maximum acceptable voltage



where does it say change ANYTHING? codes do not mean chnge a component....this COULD BE a sensor seeing an out of "range" reading....
low vac = hi voltage.....

>any other codes?
>1st what is ENG vac reading ?
I would look for a vacuum leak. try the old spray trick to locate a leaking area/component.....
Reply With Quote
  #3  
Old 08-06-2009, 07:29 PM
rabbler rabbler is offline
Record Breaker
1997 Dodge Ram 1500
 
Join Date: Jul 2007
Location:
Posts: 1,488
Default

Look for a broken wire in the MAP harness or bad contact at the connector to the sensor.
__________________
97 Ram Sport ext 4x4, 5.9L gas, 3" pro comp lift w dual shocks, 3:55 trac lock
Lt305/70R16 Kumho KL-78, K&N FIPK, Mopar Performance wires and cap, Stainless shorty headers, Walker exhaust. All syn lubes. Sirius sat radio! Magellan GPS
2003 Grand Caravan Sport. 3.3L No toys in it. Nobody's cool in a Minivan...
Reply With Quote
  #4  
Old 08-06-2009, 08:26 PM
kev2 kev2 is offline
Veteran
Garage is empty, add now
 
Join Date: Apr 2009
Posts: 339
Default

PROBE AND post Voltage use a DVOM...
back probe vio/brn wire at map sensor....signal to PCM
back probe org/pnk*....... should be 5v (referance)

* might be pnk/yellow.
Reply With Quote
  #5  
Old 08-10-2009, 12:23 PM
bullet1118 bullet1118 is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 11
Default

I tried the spray trick didn't see anything. I have someone looke at it and the pcm is bad he's going to try and get me one. I don't have anything to check the voltage. Codes I'm getting now are 1684 battery code thing, 0123, 108, and 1598
Reply With Quote
Old 08-10-2009, 12:23 PM
 
 
 
Reply




Tags
108, 1995, 2003, caravan, code, dodge, intrepid, map, neon, plymouth, problem, problems, put, ram, replace, sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 01:18 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2