2005 SXT Stereo lights on, but no sound - DodgeForum.com

Go Back   DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Log In 


Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

All times are GMT -4. The time now is 02:08 AM.>

2005 SXT Stereo lights on, but no sound

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-01-2010, 09:01 AM
BrentHamm's Avatar
BrentHamm BrentHamm is offline
Amateur
 
Join Date: Aug 2009
Vehicle: 2004 Dodge Ram Sport
Location: Altona Manitoba Canada
Posts: 38
Default 2005 SXT Stereo lights on, but no sound

I cannot figure out what is going on. The stereo lights are all on. When i push the time (or clock whatever) button i can see the time. But there is no sound, no radio stations displayed nothing.

I checked and swapped the fuses, and that did not help. Any ideas?

Thanks!
Reply With Quote
  #2  
Old 12-01-2010, 07:25 PM
sapporo sapporo is offline
Banned
 
Join Date: Jun 2010
Posts: 1,406
Default

gee, if it's on (lights up) then you have power so it's not the fuse. Ever think that maybe the radio just decided to crap out? That's my idea. heck I have a pile of factory stereos that crapped out which I've been fixing and selling on ebay over the years.
Reply With Quote
  #3  
Old 12-02-2010, 12:48 AM
master tech's Avatar
master tech master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,754
Leonard Pierce
Default

I would say the problem is with the radio. This does happen sometimes.
__________________
Dodge Master Tech.
Reply With Quote
  #4  
Old 12-02-2010, 08:16 AM
BrentHamm's Avatar
BrentHamm BrentHamm is offline
Amateur
 
Join Date: Aug 2009
Vehicle: 2004 Dodge Ram Sport
Location: Altona Manitoba Canada
Posts: 38
Default

Could be.

So, the display does not show any radio stations, but will show the time. No audio no matte what i do. All the buttons are lit up like they should be. It will accept and eject a cd, but will not play it.
Reply With Quote
  #5  
Old 12-02-2010, 07:23 PM
sapporo sapporo is offline
Banned
 
Join Date: Jun 2010
Posts: 1,406
Default

So, try a different radio. or take yours apart and figure out why it's not working, fix it and verify the repair.
Reply With Quote
  #6  
Old 01-22-2011, 09:05 PM
BrentHamm's Avatar
BrentHamm BrentHamm is offline
Amateur
 
Join Date: Aug 2009
Vehicle: 2004 Dodge Ram Sport
Location: Altona Manitoba Canada
Posts: 38
Default

Dang. Just tried installing a new stereo (Pioneer) and it does not power on.

There is a 30 Central Amp Fuse, is there another fuse for the radio?
Reply With Quote
 
 
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
schmidtp's Work Truck Thread schmidtp 2nd Gen RAM general discussion/NON-tech 14 08-22-2015 06:35 PM
Park lights eric scott 3rd Gen Dakota 5 06-18-2015 11:37 AM
Burnt Coils panteranegra 3rd Gen Ram Tech 2 06-13-2015 02:14 AM
2005 Durango Radio Issues dlewis7254 2nd Gen Durango 1 06-09-2015 03:43 PM
some part numbers? nonisossose 4th Gen Ram Tech 0 06-07-2015 02:01 PM

 
Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

Internet Brands, Inc.


Contact Details & Emails