Cruise Control Problems - DodgeForum.com



Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

Cruise Control Problems

Reply
 
 
  #1  
Old 01-07-2011, 04:03 AM
jonimsk
jonimsk is offline
Registered User
Thread Starter
 
Join Date: Jan 2011
Posts: 1
Default Cruise Control Problems

Hey everyone,
My wife has a 2007 Grand Caravan that the cruise stopped working on. I tried searching the site but couldn't find anything for the codes.

What it does: When she turns on the cruise the cruise light will flash on then immediately off, cruise never engages. After that the light wont even flash.

Using the great info on here I got the following codes from the off/run times 3

P0582 Speed Control Vacuum Selonoid Circuit
P0586 Speed Control Vent Selonoid Circuit

Any help you can give as to what to try would be much appreciated
Reply With Quote
  #2  
Old 01-08-2011, 01:08 AM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
 
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,854
Default

Welcome to DF
Send me your email address and i'll send you the PDF files for these codes.
Reply With Quote
  #3  
Old 03-20-2011, 08:51 PM
JohnBritt
JohnBritt is offline
Registered User
 
Join Date: Mar 2011
Posts: 1
Default

I have the same problem on my 06 Grand Caravan.What is the selonid and where is it located? Thanks
Reply With Quote
  #4  
Old 03-20-2011, 08:59 PM
22DODGE22
22DODGE22 is offline
Registered User
 
Join Date: Feb 2010
Location: DMS
Posts: 790
Default

The solenoids are inside of the cruise assembly unit. It has the cable attached that goes to the trottle plate
Reply With Quote
  #5  
Old 05-31-2012, 02:09 PM
DrFeelgood
DrFeelgood is offline
Registered User
 
Join Date: May 2012
Location: Iowa
Posts: 1
Default

I have exactly this same problem with my 03 Caravan SE (4 cyl). Before I found the forum I checked the vacuum line without the engine running and cleaned out the electrical connector, both of which appear to be fine. The speed control started acting odd a while back degrading to intermittently functioning and finally to the same condition as the thread starter. What are my next steps?
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
FakeBakn3
Dodge/Ram Diesel
4
07-16-2015 02:54 AM
JoshSlash87
3rd Gen Ram Tech
1
07-14-2015 08:51 AM
59skippy
Dodge Journey
5
07-06-2015 03:04 PM
kenb1023
2nd Gen Ram Tech
2
07-06-2015 01:44 PM
OptimalRhyme
2nd Gen Ram Tech
8
07-06-2015 11:06 AM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 04:06 AM.