Go Back   DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Sign in using an external account
Register Forgot Password?


Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

2001 Caravan runs 2 seconds and dies

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-07-2011, 07:06 PM
outdoorlife72 outdoorlife72 is offline
Registered User
2001 Dodge Caravan
 
Join Date: Mar 2011
Posts: 3
Default 2001 Caravan runs 2 seconds and dies

I can restart over and over and it always runs for 2 seconds and then dies. If I step on the accelerator right when it starts then it will stay running, but it is like the ignition cuts out very briefly every 2 seconds. When you get in and turn the key on, you can hear the fuel pump run for 2 seconds, stop briefly and then run for 2 second, this repeats indefinitely. I believe that I have a bad ECM, I just want to exhaust all other possibilities before I purchase a new one. This van is a very basic model and does not have a chip in the key. I have also checked the solder joints in the instrument cluster, tried a new battery, and cleaned the connections to the fuse box. The engine runs smooth for the 2 secons it runs. If you take it out and drive it, it even shifts fine. Just that the ignition cuts out briefly. Any help will be greatly appreciated.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 03-07-2011, 11:10 PM
master tech's Avatar
master tech master tech is offline
Multi-section Moderator
Garage is empty, add now
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,536
Leonard Pierce
Default

Welcome to DF
I would try an ignition switch first, Before replacing the PCM. If the engine cutting out when putting the transmission into gear, I would say the torque converter is locking up. I would also inspect the PDC/FCM and may sure you are not loosing 12v to the ASD relay.
__________________
Dodge Master Tech.
Reply With Quote
  #3  
Old 03-08-2011, 11:21 AM
Tizzy1's Avatar
Tizzy1 Tizzy1 is offline
Champion
Garage is empty, add now
 
Join Date: Jan 2010
Posts: 2,916
Default

Check for fuel pressure too, low pressure will do that. Could have a tps out of range too.
Reply With Quote
  #4  
Old 03-08-2011, 05:47 PM
outdoorlife72 outdoorlife72 is offline
Registered User
2001 Dodge Caravan
 
Join Date: Mar 2011
Posts: 3
Default

Fuel pressure is good. I dont thnk it is the switch because the pattern is that exactly every 2 seconds the ignition shuts down for exactly the same amount of time over and over. If you step on the gas so you can get the engine to ride through the ignition cut out for a while then it will actually stay running even at an idle.(once the engine has warmed slightly) It still cuts out briefly every 2 seconds. Also it does not act any different when you put it in gear, so I don't believe it is the torque converter.
Reply With Quote
  #5  
Old 03-09-2011, 01:33 AM
Cougar41 Cougar41 is offline
Record Breaker
Garage is empty, add now
 
Join Date: Feb 2011
Location: SoCal
Posts: 1,736
Default

There was a recent thread here dealing with stalling after a few seconds. They changed the MAP sensor and all was fine. They frequently fail without throwing a code. They can be tested using a vacuum tester and meter.
__________________
We took the time to answer your post. Please give us some time and post the fix. You'll help hundreds!
Reply With Quote
  #6  
Old 03-09-2011, 06:49 PM
soupdog2169 soupdog2169 is offline
Registered User
Garage is empty, add now
 
Join Date: Jul 2010
Vehicle: 2002 grand caravan 246,000 miles
Location: Buffalo NY
Posts: 12
Default

Had the same problem it ended up being the map sensor
Reply With Quote
  #7  
Old 03-16-2011, 12:47 AM
ramman2002 ramman2002 is offline
Registered User
Garage is empty, add now
 
Join Date: Mar 2011
Posts: 1
Default

Had the same problem, turned out to be ASD open relay circut , (wiring short)codes P1388 & P 1389, do by pass test on ASD and if resolved , find broken wire in harness for open circuts clean connections at PCM and Fuse box
Reply With Quote
  #8  
Old 03-16-2011, 12:11 PM
soupdog2169 soupdog2169 is offline
Registered User
Garage is empty, add now
 
Join Date: Jul 2010
Vehicle: 2002 grand caravan 246,000 miles
Location: Buffalo NY
Posts: 12
Default

I have had alot of wiring problems with my 02 most of I have traced to inside the ipm or the wires and plugs coming out of it mostly corrosion and broken wires some inside between the fuse and the harness under it I have. Quite a few jumper wires running from the fuses to the harness underneath
Reply With Quote
  #9  
Old 05-14-2011, 10:49 AM
outdoorlife72 outdoorlife72 is offline
Registered User
2001 Dodge Caravan
 
Join Date: Mar 2011
Posts: 3
Default bad ecm

Thanks to all for your input. After many evenings in the garage checking anything from coroded terminals and potentially bad sensors to looking for cracked solder joints, I replaced the ECM. Back on the road. Thanks again for all the help.
Reply With Quote
Old 05-14-2011, 10:49 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 12:22 AM.

Internet Brands, Inc.


Contact Details & Emails