Go Back   DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Sign in using an external account
Register Forgot Password?


Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

Clicking Noise coming from IPM Fuse Box

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-08-2011, 10:46 AM
quantass quantass is offline
Professional
Garage is empty, add now
 
Join Date: Dec 2009
Vehicle: 2002 Dodge Caravan SE (3.3L V6)
Location: London, Ontario CANADA
Posts: 164
Question Clicking Noise coming from IPM Fuse Box

Our 2002 Dodge Caravan SE has a clicking noise come from the IPM Fuse & Relay Center box.

When i go to start the car there is no ignition. There is no light in the car. A clicking noise can be heard coming from under the hood. When i remove the key, the clicking noise persists. I went to open the fuse box but didnt see anything unusual. I then attempted to remove / reinstall random fuses. The clicking noise persisted until i removed / reinstalled the Front Wiper Relay. I then went back to start the car but no power.

I will attempt to jumpstart the car but can someone tell me what happened to the vehicle? What the heck is this on-going clicking noise even when the car is shut off.

Thanks
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 10-08-2011, 12:09 PM
master tech's Avatar
master tech master tech is offline
Multi-section Moderator
Garage is empty, add now
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,527
Leonard Pierce
Default

You could have a bad battery and you'll getting a feed back thru the relay. You could also have a bad relay or shorted wires.
__________________
Dodge Master Tech.
Reply With Quote
  #3  
Old 10-10-2011, 02:13 AM
quantass quantass is offline
Professional
Garage is empty, add now
 
Join Date: Dec 2009
Vehicle: 2002 Dodge Caravan SE (3.3L V6)
Location: London, Ontario CANADA
Posts: 164
Default

It seems like it was the battery, thank you!

Last edited by quantass; 10-10-2011 at 02:17 AM..
Reply With Quote
Old 10-10-2011, 02:13 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 09:47 AM.

Internet Brands, Inc.


Contact Details & Emails