Go Back   DodgeForum.com > Dodge Cars > Dodge Charger
Sign in using an external account
Register Forgot Password?


Dodge Charger The Dodge Charger. The car that made its competitors shiver in the 60's is reborn in 2006 into a sleek sedan that can still send the competition home wimpering, the Dodge Charger.
Sponsored by IloveHID
Click Here


2012 police User interface failure

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-10-2012, 11:50 PM
Jeremy71655 Jeremy71655 is offline
Registered User
Garage is empty, add now
 
Join Date: Apr 2011
Posts: 5
Default 2012 police User interface failure

Hi guys, I was wondering if anyone else has experienced this. My department has purchased a 2012 police package charger. It has less than 500 miles on it and this User Interface/ radio has stopped working. The screen went blank and will not respond. I have tried a hard reset, and checked the fuses, everything is fine. The lighting on the console flashes randomly as well. I searched the recalls and havent found anything that covers this and i haven't been able to find any information on it. I am taking it to the dealer tomorrow, but i was curious if this has happened to anyone else or if there is a simple fix . Thanks!
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 04-11-2012, 08:02 AM
KRZY.BMET's Avatar
KRZY.BMET KRZY.BMET is offline
Hybrid Moderator
2009 Dodge Caliber
 
Join Date: Apr 2007
Vehicle: '09 Caliber SXT
Location: Miramar, Florida
Posts: 4,964
Default

I read about a recall last week but can't remember exactly what the problem was. I jsut remember that it involved the new police cruisers and that there were roughly 10,000 of them that needed something. I'm not to familiar with the whole police interface thing (YET), so hopefully the dealer will find it out. Please let us know what happens because we all need to be taught about the new police cruisers.

Thanks
__________________
Black 2009 Caliber SXT with some beach package
Reply With Quote
  #3  
Old 04-11-2012, 08:21 AM
Jeremy71655 Jeremy71655 is offline
Registered User
Garage is empty, add now
 
Join Date: Apr 2011
Posts: 5
Default

I definately will. This unit is so new, that we hadnt even installed any Lights or any electronics that would interfere with anything factory. When I say interface, I am merely speaking of the radio screen where you can control the climate and other adjustments. Other than some slightg performance upgrades, I am pretty sure that the police package is the same as the consumer package. I am dropping it off this morning and will post as I find out more. Thanks!
Reply With Quote
  #4  
Old 04-11-2012, 10:11 AM
DodgeCares's Avatar
DodgeCares DodgeCares is offline
Record Breaker
Garage is empty, add now
 
Join Date: Jul 2011
Location: Mopar HQ
Posts: 1,584
Default

Quote:
Originally Posted by Jeremy71655 View Post
Hi guys, I was wondering if anyone else has experienced this. My department has purchased a 2012 police package charger. It has less than 500 miles on it and this User Interface/ radio has stopped working. The screen went blank and will not respond. I have tried a hard reset, and checked the fuses, everything is fine. The lighting on the console flashes randomly as well. I searched the recalls and havent found anything that covers this and i haven't been able to find any information on it. I am taking it to the dealer tomorrow, but i was curious if this has happened to anyone else or if there is a simple fix . Thanks!
Jeremy,

I could find no recall or TSB's regarding this issue. There is one for the lights on screen being to bright but not for the issue as you described.
__________________
Regina

U.S. Top Care
Chrysler Group LLC
Reply With Quote
  #5  
Old 04-11-2012, 12:25 PM
BCP Service BCP Service is offline
Amateur
Garage is empty, add now
 
Join Date: Mar 2012
Posts: 30
Default

Yep, had a cruiser last week, Center stack went blank after sitting anywhere from 30 minutes up. Screen was unresponsive after starting vehicle. Initially we thought was interface module under radio, but after research, we replaced the TGW (Telamatics Gateway)as suggested by engineering. Vehicle has not returned w/ same concern. There is an upgrade for a condition wherein you get in and the radio is at top volumn (if built before July 25, 2011), this will not repair "unresponsive" units though ..
Reply With Quote
Old 04-11-2012, 12:25 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 04:47 AM.

Internet Brands, Inc.


Contact Details & Emails