2006 Dodge Charger Engine light blinks and beeps when I hit the brake - DodgeForum.com


Dodge Charger The Dodge Charger. The car that made its competitors shiver in the 60's is reborn in 2006 into a sleek sedan that can still send the competition home wimpering, the Dodge Charger.
Sponsored by:
Sponsored by:

2006 Dodge Charger Engine light blinks and beeps when I hit the brake

Reply
 
 
  #1  
Old 06-16-2012, 07:38 PM
dodgechar06
dodgechar06 is offline
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 3
Default 2006 Dodge Charger Engine light blinks and beeps when I hit the brake

I have a 2006 dodge charger 2.7L and every time I hit the brakes or idle the engine light blinks and the car beeps. once I step on the gas it stops and when I press on the brakes the engine light blinks and the car beeps again. This also happens when the car is idle. Everything else works just fine on the car.
Please can anyone help or has anyone ever experienced this?
Reply With Quote
  #2  
Old 06-16-2012, 11:01 PM
steak59
steak59 is offline
Record Breaker
 
Join Date: Dec 2010
Posts: 1,881
Default

get the CEL check out and post us the Code, then we can help you further.
You can do that by going to Autozone, they do it for free, or do the Key dance.
"turn key to Off, ON, Off, ON, Off, ON" without engine running. code should display in ur Odometer. Just write it all down.
Reply With Quote
  #3  
Old 06-17-2012, 09:39 PM
dodgechar06
dodgechar06 is offline
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 3
Default

Thank you I will do just that.......
Reply With Quote
  #4  
Old 06-18-2012, 12:03 PM
DodgeCares's Avatar
DodgeCares
DodgeCares is offline
Record Breaker
 
Join Date: Jul 2011
Location: Mopar HQ
Posts: 2,394
Default

Quote:
Originally Posted by dodgechar06 View Post
I have a 2006 dodge charger 2.7L and every time I hit the brakes or idle the engine light blinks and the car beeps. once I step on the gas it stops and when I press on the brakes the engine light blinks and the car beeps again. This also happens when the car is idle. Everything else works just fine on the car.
Please can anyone help or has anyone ever experienced this?
06,

Are all your brake lights working?
Reply With Quote
  #5  
Old 06-19-2012, 04:17 PM
dodgechar06
dodgechar06 is offline
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 3
Default

Yes my brake lights are working...And sorry I made a mistake on my original post, the oil light blinks intermittently not the Engine light. And this only happens when I press the brakes or when the car is on idle. Once I start moving it stops.....I tried to get codes but they couldn't because it was the oil light and not the check engine light......
Reply With Quote
  #6  
Old 06-19-2012, 04:35 PM
DodgeCares's Avatar
DodgeCares
DodgeCares is offline
Record Breaker
 
Join Date: Jul 2011
Location: Mopar HQ
Posts: 2,394
Default

Quote:
Originally Posted by dodgechar06 View Post
Yes my brake lights are working...And sorry I made a mistake on my original post, the oil light blinks intermittently not the Engine light. And this only happens when I press the brakes or when the car is on idle. Once I start moving it stops.....I tried to get codes but they couldn't because it was the oil light and not the check engine light......
06,

You need to get the oil pressure checked on your engine ASAP. Hopefully it could just be the sensor, but if your sensor is good and the oil pressure is dropping too low that could do major damage to your engine.
Reply With Quote
  #7  
Old 06-20-2012, 04:37 PM
steak59
steak59 is offline
Record Breaker
 
Join Date: Dec 2010
Posts: 1,881
Default

stupid things to check, what's the oil level?
Also, when is your last oil change? go get one too. on the 2.7L, you have to do oil change religiously at 3-5k, or else the sludge monster will eat your engine.

or maybe you just need a oil pressure sensor as Dodgecare mentioned.
Reply With Quote
  #8  
Old 06-27-2012, 06:43 PM
htate1
htate1 is offline
Registered User
 
Join Date: Jun 2012
Posts: 1
Default

Quote:
Originally Posted by dodgechar06 View Post
I have a 2006 dodge charger 2.7L and every time I hit the brakes or idle the engine light blinks and the car beeps. once I step on the gas it stops and when I press on the brakes the engine light blinks and the car beeps again. This also happens when the car is idle. Everything else works just fine on the car.
Please can anyone help or has anyone ever experienced this?
I have this same issue but dealership cannot relate to what I am saying. I have been told to bring it in when it does that but of course it never occurs when I am in the vicinity or either it happens when they are closed.
Reply With Quote
  #9  
Old 06-28-2012, 02:28 PM
POWER SEDAN's Avatar
POWER SEDAN
POWER SEDAN is offline
Captain
 
Join Date: Sep 2010
Location: Wisconsin
Posts: 664
Default

Do either of you have the optional EVIC system? You can retrieve oil pressure status while driving.
Reply With Quote
  #10  
Old 10-22-2012, 10:56 AM
Android84
Android84 is offline
Registered User
 
Join Date: Oct 2012
Location: Juarez, Mexico
Posts: 2
Exclamation

Quote:
Originally Posted by DodgeCares View Post
06,

You need to get the oil pressure checked on your engine ASAP. Hopefully it could just be the sensor, but if your sensor is good and the oil pressure is dropping too low that could do major damage to your engine.
Hi Dodgechar06!

Did you found the problem? I think I have the same issue with my car and just start yesterday with it any feedback will be appreciated.

Thanks!
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Lyniaer
1st Gen Durango
2
11-12-2015 02:39 PM
swamper
3rd Gen RAM general discussion/NON-tech
9
07-21-2015 06:08 AM
Daug
Dodge Stratus
5
07-04-2015 08:00 PM
kevkev
Dodge Charger
4
07-04-2015 01:05 PM
arty278
New Member Area
1
07-03-2015 03:07 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 11:15 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send