Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > Dodge Cummins Diesel
Sign in using an external account
Register Forgot Password?


Dodge Cummins Diesel Discuss all generations of Cummins Diesel powered Ram's within Dodge Diesel Forum.

Check Engine Light blinks 10 times, three others lights not illuminating

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-30-2009, 10:49 AM
bataradena bataradena is offline
Registered User
Garage is empty, add now
 
Join Date: Jan 2009
Posts: 11
Default Check Engine Light blinks 10 times, three others lights not illuminating

HELP!
I just purchased a uses 2006, 2500 quad cab 4X4 truck with the Cummins Diesel engine and I’m wondering about Check Engine Light and about there others lights on my instrument panel that appears not to be working.

The Check Engine Lights turns on, steady light for about 15 seconds, and then flashes 10 times, then returns back to a steady light. User manual reads “Five Flashes” means “Not Read for Emission”, but I’m getting “Ten Flashes”. Is this a real problem or has this been changed with the updated ECM code that was programmed sometime before my purchase?

Next question: I also noticed after the key is first turned on, with the engine not started, most lights are illuminating but three lights are not….

1 Wait to Start Indicator
2 Water in Fuel Indicator
3 SERV 4WD Indicator

Is this normal, or is there a way to test the lights to make sure they are working or do I have a problem that needs further investigation.

Thanks for the help
Byron
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 09-30-2009, 06:26 PM
BrianSudokhoi02 BrianSudokhoi02 is offline
Veteran
Garage is empty, add now
 
Join Date: May 2007
Vehicle: 07 2500 CTD
Location: SE MN
Posts: 470
Default

You are being too paranoid. My truck does all the same stuff and has since it was new. The wait to start light only comes on when all the temp sensors are indicating 59 degrees (aprox.) or lower. I have heard of people that didn't have the water in fuel light working and put in a brand new instrument cluster, and it still didn't work. If that light ever does come on, you're F'd any way. It's already too late and damage has been done. Never had the SERV 4WD light work on mine either.
__________________
07 Ram 2500 Quad Cab w/Cummins 5.9
Automatic Transmission, Husky rear mats and mud flaps, Nasta stainless nerf bars, Bushwacker bed rail caps, lorado tonneau cover
Reply With Quote
  #3  
Old 09-30-2009, 07:38 PM
NickBeek NickBeek is offline
Record Breaker
Garage is empty, add now
 
Join Date: Jul 2006
Location: Upstate, SC
Posts: 1,809
Default

Start with the key in the off position, turn it to the on position but don't go all the way to start, turn it off, on, off, on rapidly. Then look at the odometer. If there are any codes stored in the computer they will show up in the odometer. If there are no codes or the codes have finish it will read -----done----.
__________________
2006 Ram 2500 CTD SLT 4X4 Thunder Road 6 Speed QCab LWB Mineral Grey, High Idle Feature. Smarty Jr, Grand Rock 6" miter cut stacks, silencer ring gone, gutted torque tube.
Reply With Quote
  #4  
Old 10-01-2009, 10:14 AM
bataradena bataradena is offline
Registered User
Garage is empty, add now
 
Join Date: Jan 2009
Posts: 11
Thumbs up

Quote:
Originally Posted by BrianSudokhoi02 View Post
You are being too paranoid. My truck does all the same stuff and has since it was new. The wait to start light only comes on when all the temp sensors are indicating 59 degrees (aprox.) or lower. I have heard of people that didn't have the water in fuel light working and put in a brand new instrument cluster, and it still didn't work. If that light ever does come on, you're F'd any way. It's already too late and damage has been done. Never had the SERV 4WD light work on mine either.


Paranoid is a good word... Never owned a new vehicle with the OBD-II. I did purchase a OBD-II scanner double checked the DTC and then erased the codes. After a 30 mile drive to work no new DTC, but the CEL still blinks ten times not five as noted in the user manual. I read in another thread about a person could induced a fault my stalling the truck while in gear (I have 6 speed). I have don this twice sense owning the truck for two weeks.

As for the "Wait to start light", "SERV 4WD" and the "Water In Fuel Indicator" as in your truck, these light do not come one during the Custer Light check? Do I have this correct?.

Thanks for the rely
Byron T
Reply With Quote
  #5  
Old 10-01-2009, 10:25 PM
BrianSudokhoi02 BrianSudokhoi02 is offline
Veteran
Garage is empty, add now
 
Join Date: May 2007
Vehicle: 07 2500 CTD
Location: SE MN
Posts: 470
Default

The wait to start light should come on during the cluster light check
__________________
07 Ram 2500 Quad Cab w/Cummins 5.9
Automatic Transmission, Husky rear mats and mud flaps, Nasta stainless nerf bars, Bushwacker bed rail caps, lorado tonneau cover
Reply With Quote
  #6  
Old 08-20-2010, 03:40 AM
imacpc imacpc is offline
Registered User
Garage is empty, add now
 
Join Date: Aug 2010
Posts: 2
Cool hwo to TEST your instrument cluster and guages

press n hole the trip odometer and move the key to ACC
it will reset/center all guages and turn on all lights
this i found in the manual
Reply With Quote
Old 08-20-2010, 03:40 AM
 
 
 
Reply




Tags
10, blinks, charger, check, cummins, diesel, dodge, doit, engine, flashes, fuel, indicator, light, neon, srt4, times, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 09:43 AM.

© Internet Brands, Inc.


Contact Details & Emails