Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > Dodge Cummins Diesel
Sign in using an external account
Register Forgot Password?


Dodge Cummins Diesel Discuss all generations of Cummins Diesel powered Ram's within Dodge Diesel Forum.

Running Rough

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-01-2010, 08:41 PM
Chuck0129 Chuck0129 is offline
Registered User
Garage is empty, add now
 
Join Date: Jun 2010
Posts: 2
Default Running Rough

Having trouble with my 06 cummins and need help figuring out.
The truck is running rough, smoking, pretty good knock, and every once in a while going down the highway it revs high until I put my foot into the accelerator and let off. I have changed the fuel filter and bled it several times. think maybe bad diesel but the reving up has me nervous. Any help would be greatly appreciated.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!

Last edited by Chuck0129; 06-01-2010 at 08:45 PM..
Reply With Quote
  #2  
Old 06-01-2010, 10:08 PM
badblackram06's Avatar
badblackram06 badblackram06 is offline
Veteran
2006 Dodge Ram 1500
 
Join Date: Jan 2009
Vehicle: 06 Ram 1500 SLT 4.7L
Location: Southwest, MS
Posts: 477
Default

Usually a mixture of Gas in the diesel make a diesel engine rev up involuntarily, knock, and run rough but i'm sure this isnt the case. I would suspect the injectors or injector pump. I drove a cummins for my dad not to long ago and the injector pump was going out and it would rev up going down the road. It eventually didnt run anymore after a few days. But i hope your problem is just bad diesel.
__________________

NEXT: wheels
2006 Ram 1500 4.7
Reply With Quote
  #3  
Old 06-01-2010, 10:10 PM
dirtydog's Avatar
dirtydog dirtydog is offline
Moderate User
2008 Dodge Ram 1500
 
Join Date: Oct 2008
Vehicle: 2008 Ram QC 4x4 BigHorn
Location: Albany, NY
Posts: 10,586
Send a message via Yahoo to dirtydog
Default

I'll move this to the Cummins section for better results
__________________
4-OEM TPM Sensors FOR SALE

Reply With Quote
  #4  
Old 06-02-2010, 06:58 AM
Coal Train's Avatar
Coal Train Coal Train is offline
All Star
Garage is empty, add now
 
Join Date: Dec 2008
Vehicle: 2006 Twin Turbo CTD, 742 HP/ 1456 TQ
Location: East Alabama
Posts: 863
Default

You've got one of two problems.

It's either 1 - the fuel control actuator (most likely, due to the revving up you're describing), or 2 - You have an injector sticking open.

Your best bet is the bring it to the dealer, have them hook it to the StarScan or StarMobile and do the following tests.

1 - Injector Kill Test. Shuts down individual injectors to find the one causing the smoke, rough idle, etc.

2 - Cylinder contribution test. This will tell you if you have an injector solenoid crapping out.

3 - You need to see the rail pressure. Both the requested pressure from the ECM and the actual pressure at the rail. This will tell you if the FCA is shot.
__________________


That thing gotta Hemi?...... I guess ya better bring two of 'em then!
Reply With Quote
  #5  
Old 06-02-2010, 09:17 PM
NickBeek NickBeek is offline
Record Breaker
Garage is empty, add now
 
Join Date: Jul 2006
Location: Upstate, SC
Posts: 1,809
Default

Coal Train is dead on. Have those tests run and let us know what the results are.
__________________
2006 Ram 2500 CTD SLT 4X4 Thunder Road 6 Speed QCab LWB Mineral Grey, High Idle Feature. Smarty Jr, Grand Rock 6" miter cut stacks, silencer ring gone, gutted torque tube.
Reply With Quote
  #6  
Old 06-10-2010, 09:54 PM
Chuck0129 Chuck0129 is offline
Registered User
Garage is empty, add now
 
Join Date: Jun 2010
Posts: 2
Default

Thanks for the help. Unfortunally I am dealing with the worst shop in the world. Not living close to a certified mechanic I had the truck towed about 60 miles to the dealer I bought it from. Their service advisor would not let me talk to the mechanic. Said he was to busy. Anyhow they reported that I had water and dirt in the fuel system. The dirt was causing the injectors to stick. They cleaned the system and told me to come pick up the truck. They told me it would take a little while for the rest of the water to go through the system. While driving the truck home it did perform better but ran rough at times and it did one time start revving again. This time it did not rev up as much as it just stayed where it was after I let off the accelerator. I put the truck in nuetral and pulled over. Kicked the pedal and it cleared up. I dont know if they fixed anything or not. I dont see why I would have to run excess water out of the system if they cleaned it out. Best I can tell by way of Hanes Manual everything gets purged during cleaning. Maybe it will be ok. Any experienced opinions would be greatly appreciated.
Reply With Quote
  #7  
Old 06-11-2010, 10:59 AM
Coal Train's Avatar
Coal Train Coal Train is offline
All Star
Garage is empty, add now
 
Join Date: Dec 2008
Vehicle: 2006 Twin Turbo CTD, 742 HP/ 1456 TQ
Location: East Alabama
Posts: 863
Default

That revving is due to rail pressure staying elevated in the rail.

That is 100% the fuel control actuator.

If you go back to the dealer, ask if they have an actual diesel tech? Then, give me a call and put me on the phone with the guy so I can tell him what the hell he needs to do.

Most dealerships don't have a full time diesel tech and finding one the knows what the hell he's doing is even more difficult.

PM me if you need a phone number.

I'm tellin' ya, this is an easy fix that you can do your self. It's a 15 minute job to swap the FCA. It's 3 torx head bolts and 1 electrical connector.
__________________


That thing gotta Hemi?...... I guess ya better bring two of 'em then!
Reply With Quote
  #8  
Old 06-13-2010, 10:42 PM
YAMAHARIDER5 YAMAHARIDER5 is offline
Professional
Garage is empty, add now
 
Join Date: Aug 2006
Vehicle: 2001 Dodge Ram 3500 CTD
Location: Avondale az/morganton nc
Posts: 145
Default

Coal train could it possibly be the fuel rail pressure sensor? If it has a fault it will go to max fuel rail presure determinded by the ecm correct?
__________________
01 3500 4x4, edge comp,sbc clutch,stage 2 jammer nozzels,4 inch straight pipe,amsoil cai,aurura 3000,raptor fuel pump,autometer gauges
Reply With Quote
  #9  
Old 06-14-2010, 08:38 AM
Coal Train's Avatar
Coal Train Coal Train is offline
All Star
Garage is empty, add now
 
Join Date: Dec 2008
Vehicle: 2006 Twin Turbo CTD, 742 HP/ 1456 TQ
Location: East Alabama
Posts: 863
Default

It could be, but not likely. That always sets a code.

There are a few things that can go bad and not set a code, they're all mechanical and aren't monitored by a sensor.

If the FCA fails mechanically, it won't set a code. If it fails electronically, it sets a code.

If the injectors fail below the solenoid, it won't set a code. If the solenoid fails, it sets a code.

Pretty much everything else in the fuel system is monitored electronically.

What you can do is pull the FCA out (very easy, just 3 torx head bolts) and shake it back and forth. If it rattles, it's good. If it doesn't rattle, it's stuck and needs to be replaced.

The injectors are a bit harder to see. You have to pull them out and inspect them under a magnifying glass (in most cases, unless it's REALLY catastrophic). What you normally see there is a crack in the injector body or the nozzle, usually both.

These pictures are tough to tell, but here is what you see when it's a cracked injector body and nozzle. Usaully you have to use a magnifying glass or you have to put the injector on the flow bench to see if it's cracked.

You can kind of see in the first picture where the body is cracked by the fuel passage (the hole at the 5 o'clock on the face).

In the second picture, you can see the discoloration by the hole that is also in the 5 o'clock position. You can't tell in this picture, but the face of that nozzle is actually spider webbed all the way across it. Much longer and that would have be a catastrophic failure resulting in a motor rebuild.

Normally, when this happens, it's accompanied by HUGE amounts of white smoke at idle and the idle is rough. It's easy to figure out with the StarScan, all you have to do is shut down the injectors until the one you shut down causes the smoke to stop and the idle to smooth out.

Click the image to open in full size.

Click the image to open in full size.
__________________


That thing gotta Hemi?...... I guess ya better bring two of 'em then!

Last edited by Coal Train; 06-14-2010 at 08:43 AM..
Reply With Quote
Old 06-14-2010, 08:38 AM
Reply
 
 
 




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 02:29 PM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2