2013 Journey SXT UConnect problems. - DodgeForum.com


Dodge Journey Dodge Journey forum for discussion on the popular Dodge Crossover and CUV.

2013 Journey SXT UConnect problems.

Reply
 
 
  #1  
Old 03-11-2017, 08:20 PM
taldeb
taldeb is offline
Registered User
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Question 2013 Journey SXT UConnect problems.

2013 Journey SXT
Hi, our UConnect started having issues last week. First there was no audio output for the radio. Then no airflow for the fan. Yesterday the fan worked, but no air or heat. Today the airflow for the fan is working, but the cold air comes and goes. Still no audio for radio and the screen is glitching. The Dodge screen appears as normal and it switches to UConnect as normal, but it gets stuck on the loading for 10-20 secs and then switches back to the Dodge screen. It just continues to loop like that. Can anyone help? Any suggestions are appreciated! Thanks ☺
Reply With Quote
  #2  
Old 03-12-2017, 09:13 AM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
 
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 19,173
Default

Disconnect the battery for a bit. If that does not work, the module is probably going bad and will require a replacement.
Reply With Quote
  #3  
Old 03-13-2017, 03:09 PM
taldeb
taldeb is offline
Registered User
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Default

It worked! Thanks so much!!
Reply With Quote
 
 
Reply



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 06:19 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send