2000 neon oil light "ON" and engine shut off after driving about 30 km. - DodgeForum.com


Dodge Neon The sport compact car that took the world by storm. the Dodge Neon. Depending on the trim level you get, this sporty ride has something to offer everyone.

2000 neon oil light "ON" and engine shut off after driving about 30 km.

Reply
 
 
  #1  
Old 06-07-2011, 11:59 PM
Seaeagle
Seaeagle is offline
Registered User
Thread Starter
 
Join Date: Jun 2011
Posts: 4
Default 2000 neon oil light "ON" and engine shut off after driving about 30 km.

Hi all:

My 2000 neon will shut off the engine after driving about 30km and Oil light on the dash will go on. The engine can restarts only after shutting off for a while.

It won't do this on me in the morning on the way to work but will in the afternoon on my way home.

Did an oil change last night and it happened again today.

Could it be a faulty oil pressure sender that caused this problem?

Thanks for help

Terry
Reply With Quote
  #2  
Old 06-08-2011, 12:12 AM
darthroush's Avatar
darthroush
darthroush is offline
Section Moderator
Dodge Forum Moderator
 
Join Date: Sep 2008
Location: Northern California
Posts: 5,491
Default

A bad sender won't shut the engine off. Is the CEL on?
Reply With Quote
  #3  
Old 06-08-2011, 12:31 AM
Seaeagle
Seaeagle is offline
Registered User
Thread Starter
 
Join Date: Jun 2011
Posts: 4
Default

Only oil light is on ,no other lights on.
Reply With Quote
  #4  
Old 06-15-2011, 01:58 PM
krohal
krohal is offline
Registered User
 
Join Date: Jun 2011
Posts: 1
Default

Ive bee having the same problem with my '02. Ive noticed that it has to do with the autoshutdown relay located in the fusebox under the hood. Ive replaced the relay but still have the problem. Ive also noticed that it happens alot after i hit a hard bump in the road. When it shuts down i pop the hood and mess with the fusebox and relays and then the car will start right back up. idk if this is the same issue but hopefully this helps. goodluck
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rampuppy
Archived Classifieds
3
07-08-2015 04:10 AM
Hemibuck
3rd Gen Durango
3
07-07-2015 11:51 AM
500e
Dodge Charger
1
07-05-2015 11:23 AM
500e
Dodge Charger
0
07-05-2015 11:20 AM
arty278
New Member Area
1
07-03-2015 03:07 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 12:07 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send