2004 Neon wipers won't stop running - DodgeForum.com


Dodge Neon The sport compact car that took the world by storm. the Dodge Neon. Depending on the trim level you get, this sporty ride has something to offer everyone.

2004 Neon wipers won't stop running

Reply
 
 
  #1  
Old 07-14-2014, 10:11 PM
Mike E
Mike E is offline
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 2
Default 2004 Neon wipers won't stop running

Hey, I just bought a 2004 Neon with a problem.
When the car is not running I can turn the ignition switch to "on" and the wipers work normally, on, off, delay...
If I start the engine, wipers run all the time and will not turn off.
Get this...
If I step on the brake the wipers stop. If I let go the brake the wipers start going again.
Does anyone have any idea what could be causing this?
I have tryed 2 other multifunction switches and same thing. I have switched the wiper motor, same thing.
Is there a relay in this circuit? If so, where is it?
Thanks much, Mike
Reply With Quote
  #2  
Old 08-30-2015, 06:46 PM
winr
winr is offline
Registered User
 
Join Date: Aug 2015
Posts: 2
Default what happened?

Mike what was the resolution of the wiper issue???
Reply With Quote
  #3  
Old 09-01-2015, 10:17 PM
winr
winr is offline
Registered User
 
Join Date: Aug 2015
Posts: 2
Default my solution

Ok since Mike dosnt seem to be on here much and I needed to get my Daughters car finished I had to diagnose the answer myself (no shortcuts)
The answer is... a bad (shorted)washer pump motor and multi function switch(stuck on wash).
I got ahold of a wiring diag and started pining things out and found power going to the washer pump (at the switch) but the pump was not running, so I unplugged the pump and voila...issue gone. The stalk wasn't in the wash position so it must be stuck/shorted.
Reply With Quote
  #4  
Old 09-02-2015, 09:08 AM
Mike E
Mike E is offline
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 2
Default

Sorry for the delay, computer issues...


That was the solution for me too. I unplugged the windshield washer pump and everything worked fine after that. I just left it unplugged.
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stonernate
Dodge Neon
1
02-07-2016 04:02 PM
goddesserika
Dodge Stratus
2
07-14-2015 08:28 PM
Turbojimmy
Dodge Caravan
4
07-13-2015 09:29 PM
dss56
3rd Gen Ram Tech
8
07-09-2015 09:01 PM
colons3499
Dodge Neon
0
07-09-2015 03:57 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 01:50 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send