Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > Dodge/Ram Diesel
Sign in using an external account
Register Forgot Password?


Dodge/Ram Diesel Discussions on all generations of Cummins Diesel powered Rams plus the new Eco Diesel

Edge Juice Problems

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-16-2008, 11:39 PM
Big_B Big_B is offline
Rookie
Garage is empty, add now
 
Join Date: Jun 2008
Vehicle: Ram 2500 4" exhaust, K&N cold air, Edge Juice w/Attitude, 305/70 BFG AT's
Location: Reno, NV
Posts: 98
Unhappy Edge Juice Problems

I have no idea what to make of this. I was out getting firewood this weekend and when i was leaving my mom hit volume **** to switch to the clock. Then no sound anymore, nothing from the radio CD's, or cassette. Ok i can deal with that..

Then a few days later Im gettin on the freeway and the motor drops in power. My chip had turned off and came back on. Weird I can still deal with that too. Later that day I'm headed home and it turns on and off 4 times. Now to top it all of today, the chip was giving me a "accept terms and conditions" message. Gave me 4 warnings to accept, and I did. Now I have only stock power, my turbo cool down doesnt work, ect. Anyway one every expeirrence this? BTW my chip is Edge Juice with Attitude.

My low wash fluid light is on.. But I think thats just because it is actaully low lol.

Thanks all.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 12-17-2008, 12:43 AM
scatpack_69's Avatar
scatpack_69 scatpack_69 is offline
All Star
Garage is empty, add now
 
Join Date: Jul 2007
Vehicle: Hmm....Dodges!!
Location: Wyoming
Posts: 759
Default

Is there any loose connections? Check the connection at the data link, make sure nothings loose.

Have you tried unplugging it and plugging it back in?

If that doesnt work, call up Edge.
__________________
2007 Dodge Ram 3500 5.9 Cummins-Goerend-Hamilton-EFILive
2003 Dodge Ram 2500 5.9 Cummins HO-NV5600-6.7 swap
1970 Challenger 318/auto, soon to be 390 stroker
1968 RoadRunner 440/auto. 1968 Satellite 318/auto on the rotisserie
Reply With Quote
  #3  
Old 12-17-2008, 01:48 PM
Big_B Big_B is offline
Rookie
Garage is empty, add now
 
Join Date: Jun 2008
Vehicle: Ram 2500 4" exhaust, K&N cold air, Edge Juice w/Attitude, 305/70 BFG AT's
Location: Reno, NV
Posts: 98
Default

Yea I tried all that. I'm on the phone with them right now. I sent an email to them yesterday and they said I will have to mail it to them for diagnostics and repair. Oh well I guess. Where is the radio section of this forum... I need help fixing my radio that just quit producing sound.
Reply With Quote
  #4  
Old 12-19-2008, 09:31 PM
Big_B Big_B is offline
Rookie
Garage is empty, add now
 
Join Date: Jun 2008
Vehicle: Ram 2500 4" exhaust, K&N cold air, Edge Juice w/Attitude, 305/70 BFG AT's
Location: Reno, NV
Posts: 98
Default

Chip started working again yesterday... Must have been a bad connection somewhere. I will check out all the plugs and such when it warms up a bit.
Reply With Quote
Old 12-19-2008, 09:31 PM
 
 
 
Reply




Tags
2500, 3500, attitude, check, chip, codes, cummins, diesel, dodge, edge, forum, juice, problem, problems, ram

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 12:02 AM.

Internet Brands, Inc.


Contact Details & Emails