Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > Dodge/Ram Diesel
Sign in using an external account
Register Forgot Password?


Dodge/Ram Diesel Discussions on all generations of Cummins Diesel powered Rams plus the new Eco Diesel

truck wont downshift.

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-18-2010, 05:25 PM
slimkip slimkip is offline
Registered User
Garage is empty, add now
 
Join Date: Apr 2010
Vehicle: 06 dodge ram 3500 4x4
Location: canyon lake
Posts: 9
Default truck wont downshift.

When i come to a stop my truck will not down shift back to first, it will stay in second or third. took it to the dealer, said i had low voltage so i put two new batteries in it. it worked for a while then i hauled a trailer about 4 hours and it started agian. they also said there was something about a low line pressure, or something like that when they did diagnostic. havent had them check anything since then. looking for ideas or thoughts, its an 06 cummins, auto tranny.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 10-18-2010, 06:16 PM
dodgetrucker75's Avatar
dodgetrucker75 dodgetrucker75 is offline
Record Breaker
Garage is empty, add now
 
Join Date: Aug 2007
Vehicle: 1948 12v cummins powered B1C pickup
Location: live oak, ca
Posts: 2,267
Default

replaceing the govenor pressure solinoid and pressure sensor (inside the pan) normally cures the problem and with the code of line pressure, i bet that is it
__________________
98-12v cummins converted from v10,cammed,nv4500,compound turbos,SB3600DD,heavily modified
07 red mega cab long bed,cummins 5.9,G56,mygig,southbend, smarty, more... 99 1500 4bt
The woman's-02 cummins,3500 dually,NV5600,lifted,some added fuel, and 2013 dart 2.0 6spd
Reply With Quote
  #3  
Old 10-24-2010, 10:46 PM
slimkip slimkip is offline
Registered User
Garage is empty, add now
 
Join Date: Apr 2010
Vehicle: 06 dodge ram 3500 4x4
Location: canyon lake
Posts: 9
Default

awesome, i got those part and swapped them out. im think within the next 500 miles will tell me whether its fixed or not. but if not ill keep posted. thanks for the advice.
Reply With Quote
Old 10-24-2010, 10:46 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 08:55 AM.

Internet Brands, Inc.


Contact Details & Emails