Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > Dodge/Ram Diesel
Sign in using an external account
Register Forgot Password?


Dodge/Ram Diesel Discussions on all generations of Cummins Diesel powered Rams plus the new Eco Diesel

can-c bus communication issue. please read.

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-30-2010, 11:06 AM
fredguy fredguy is offline
Registered User
Garage is empty, add now
 
Join Date: Nov 2010
Posts: 6
Default can-c bus communication issue. please read.

i have changed the PCM and when i programmed the ECU it dissapears from the can-c bus!?

ive checked power and earth to pcm an both can-c plus and minus they are OK i have put 12v 55w loads on them as well, the cables are ok. i have also replaced the TIPM but i cant get either the old or the new one to communicate with the PCM.

It could be a scantool problem, my mechanic only have the starscan scantool and im beginning to wonder if there is a problem with the tool/cable? but why we have contact with the PCM before we flashed it?

we are working on a ram 3500 cummins 5.9 HO

me and my mechanic have done everything we can, please give me opinions and tips or such wich can help me get the truck going.

we dont know what happened to the truck but after it had went on a boat trip it didnt start and the 30A PCM fuse was blown also.

one more thing, the truck will start with the old TIPM (FCM, CENTRAL GATEWAY) but i cant drive it. but it wont start with the new TIPM because i cant program it, it doesent know the VIN and none of the configuration.

restore vehicle configuration will not work because the lack of communication between the scantool and the PCM and TIPM -->PCM

thanks for any help!
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!

Last edited by fredguy; 11-30-2010 at 04:31 PM..
Reply With Quote
  #2  
Old 11-30-2010, 11:54 AM
dirtydog's Avatar
dirtydog dirtydog is offline
Moderate User
2008 Dodge Ram 1500
 
Join Date: Oct 2008
Vehicle: 2008 Ram QC 4x4 BigHorn
Location: Albany, NY
Posts: 10,781
Send a message via Yahoo to dirtydog
Default

Sounds like you have a short or an open circuit on one of the Can c wires. You cannot check just the wires going to the PCM, as they are part of a multiplex circuit. Your mechanic should have acess and understand how to check all the individual circuits which branch out to a few other devices such as the airbag module, bcm..etc If one of the devices has a faiure it can cause your problem, so it may not even be your pcm that has gone bad, but an external device.
You need to check the OBD-II wires and see if they have lost communication when pulgging in the Scantool itself. Can your mechanic acess the pcm configurations with the tool?

This is the problem with scantools. They dumb down all the mechanics in this world and they cannot diagnose anything without communication with the handheld. Find another mechanic, one who knows how to read schematics and probe the proper wires.

If your mechanic has gone through everything, put in the old tipm and restore factory settings and do the config with the new PCM. Install the new tipm and then do a vehicle reconfig once again and see if that does anything.
You can only reconfig a tipm 4 or 5 times and then it will be bad, so good luck.
__________________
Reply With Quote
  #3  
Old 11-30-2010, 01:34 PM
weedahoe's Avatar
weedahoe weedahoe is offline
Site Moderator
Dodge Forum Moderator
Garage is empty, add now
 
Join Date: Mar 2009
Vehicle: 04 Dodge Ram QC
Location: South GA
Posts: 18,756
TrickedOut DodgeRam Weedahoe1977
Send a message via AIM to weedahoe Send a message via MSN to weedahoe Send a message via Yahoo to weedahoe
Default

Being you are also working on a CTD, let us move this over to the correct section so maybe some smart CTD guys can help out
Reply With Quote
  #4  
Old 11-30-2010, 01:55 PM
broncoremy broncoremy is offline
Professional
2003 Dodge Ram 1500
 
Join Date: Oct 2010
Vehicle: 2003 1500 5.7L
Location: North Dallas area
Posts: 145
Default

If you think the scan tool is the problem, ask your mechanic to run the scan tool on another vehicle to confirm that the scan tool is not the problem.
Reply With Quote
  #5  
Old 11-30-2010, 02:32 PM
fredguy fredguy is offline
Registered User
Garage is empty, add now
 
Join Date: Nov 2010
Posts: 6
Default

hello again, this is the mechanic speaking:

i can not access the PCM with the scantool, but BEFORE i put the ECU flash file into the brand new PCM i could access the PCM. but after i Flashed it i no longer can access it. this is a really strange fault. And if the TIPM dont have communication with the PCM i cant do a restore vehicle config.

BUT heres the strange part, the engine will start but the ar wont drive, i also havent got the frames or numbers/letters in the CCN witch shows what position the gear lever is in.

ok here it is: the can c plus and minus wires is good from the data link connector and to the tipm, they are not shorted and there is nothing wrong that way, now from the tipm and out to the PCM the can-c wiring also i good, they are not shorted or broken either between the tipm, the ABS or PCM. a current of 12volts and 55watts have been testet throug all the individual wiring to ensure they are good. (only wire-by-wiry of course, no current hav been added to any control units only the wiring between them.

the only other controller besides the PCM in the can-c on this vehicle is the ABS and i have tried to run the programs both with the ABS plugged in- and without it.
Reply With Quote
  #6  
Old 12-04-2010, 04:28 AM
fredguy fredguy is offline
Registered User
Garage is empty, add now
 
Join Date: Nov 2010
Posts: 6
Default

are there not anyone out there who could have a clue what my problem with this car could be?

thanks
Reply With Quote
Old 12-04-2010, 04:28 AM
 
 
 
Reply




Tags
3500, cummins, ecm, pcm, programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 07:51 AM.

Internet Brands, Inc.


Contact Details & Emails